summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-05-26 20:38:50 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-05-26 20:39:03 -0400
commit6076bef915626b716b5b7f8e832d28b043745f4e (patch)
tree2b08b3d868aac727b8b4ad575f2973b8077030f3 /sys-apps/apply-default-acl
parentsys-fs/zfs: revbump 0.8.4, fix not loading /etc/conf.d/zfs (diff)
downloadgentoo-6076bef915626b716b5b7f8e832d28b043745f4e.tar.gz
gentoo-6076bef915626b716b5b7f8e832d28b043745f4e.tar.bz2
gentoo-6076bef915626b716b5b7f8e832d28b043745f4e.zip
sys-apps/apply-default-acl: new version 0.4.3.
This new version includes a pkg-config file, and some upstream fixes for bugs that were reported on Gentoo. Closes: https://bugs.gentoo.org/712844 Closes: https://bugs.gentoo.org/725536 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sys-apps/apply-default-acl')
-rw-r--r--sys-apps/apply-default-acl/Manifest1
-rw-r--r--sys-apps/apply-default-acl/apply-default-acl-0.4.3.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/sys-apps/apply-default-acl/Manifest b/sys-apps/apply-default-acl/Manifest
index 2ccca958fba0..19ce38577d40 100644
--- a/sys-apps/apply-default-acl/Manifest
+++ b/sys-apps/apply-default-acl/Manifest
@@ -1 +1,2 @@
DIST apply-default-acl-0.4.2.tar.xz 246660 BLAKE2B dfb698d6a220b426ea607a70e1c51295629e6ac4637de72cf64a8fe577ed83ceaf6beb7f8b1507ed0d059e6f16e88e1b58a24e641dd6280765c55a70fa30712c SHA512 afe3a0182b76689e41d3a6922a8459587f6013112767ab0d9b60e5197d677ee0cdabd9ebd18f9cb59d4e373b4df2f5845cabddbd382c2743a80c3a20205aa861
+DIST apply-default-acl-0.4.3.tar.xz 251744 BLAKE2B 81803993ba20a7098de2767650b452df11b065e9d130199c1b12fed52f48d4676cbc8d826735d6a62d16211f51d67131e8b379feb1f0464b8ee3999cfce77e74 SHA512 d0b14bc685129e62f244a21921f271bc7baf7f2bea1c7a3689768e4205b10092154cc84cc8136b7afd37abf0259aaa23e5049b67476a8afddcc3a2be894bc423
diff --git a/sys-apps/apply-default-acl/apply-default-acl-0.4.3.ebuild b/sys-apps/apply-default-acl/apply-default-acl-0.4.3.ebuild
new file mode 100644
index 000000000000..956755978eab
--- /dev/null
+++ b/sys-apps/apply-default-acl/apply-default-acl-0.4.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Apply default POSIX ACLs to files and directories"
+HOMEPAGE="http://michael.orlitzky.com/code/apply-default-acl.xhtml"
+SRC_URI="http://michael.orlitzky.com/code/releases/${P}.tar.xz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-apps/acl"
+RDEPEND="${DEPEND}"
+
+DOCS=( doc/README )
+
+# tests need to be executed on filesystem with ACL support
+# skipping them for now
+RESTRICT="test"
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}