summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-20 11:53:10 +0000
committerSam James <sam@gentoo.org>2022-01-20 12:02:08 +0000
commit3eb4520c365bd11a227a3f56dfbfffa4c4bfb1c4 (patch)
tree3cfd9e900a58f18f09170cdbdf807b93d541f61e /sys-apps/ethtool/ethtool-5.16.ebuild
parentapp-text/lesspipe: drop 1.85, 1.89, 1.90, 2.00 (diff)
downloadgentoo-3eb4520c365bd11a227a3f56dfbfffa4c4bfb1c4.tar.gz
gentoo-3eb4520c365bd11a227a3f56dfbfffa4c4bfb1c4.tar.bz2
gentoo-3eb4520c365bd11a227a3f56dfbfffa4c4bfb1c4.zip
sys-apps/ethtool: add 5.16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/ethtool/ethtool-5.16.ebuild')
-rw-r--r--sys-apps/ethtool/ethtool-5.16.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/sys-apps/ethtool/ethtool-5.16.ebuild b/sys-apps/ethtool/ethtool-5.16.ebuild
new file mode 100644
index 000000000000..ac936a3334cd
--- /dev/null
+++ b/sys-apps/ethtool/ethtool-5.16.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Utility for examining and tuning ethernet-based network interfaces"
+HOMEPAGE="https://www.kernel.org/pub/software/network/ethtool/"
+SRC_URI="https://www.kernel.org/pub/software/network/ethtool/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+netlink"
+
+BDEPEND="app-arch/xz-utils"
+RDEPEND="netlink? ( net-libs/libmnl )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_enable netlink)
+}