summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-08-05 08:39:31 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-08-05 08:39:57 +0200
commit700f2ea5e9b992a67ac720f8e040201d4002468f (patch)
treef606add78b24f94a1ebc79cddb1e4350bd90c1c2 /sys-apps/ethtool/ethtool-5.8.ebuild
parentsys-fs/exfatprogs: Initial commit (diff)
downloadgentoo-700f2ea5e9b992a67ac720f8e040201d4002468f.tar.gz
gentoo-700f2ea5e9b992a67ac720f8e040201d4002468f.tar.bz2
gentoo-700f2ea5e9b992a67ac720f8e040201d4002468f.zip
sys-apps/ethtool: Bump to version 5.8
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/ethtool/ethtool-5.8.ebuild')
-rw-r--r--sys-apps/ethtool/ethtool-5.8.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/sys-apps/ethtool/ethtool-5.8.ebuild b/sys-apps/ethtool/ethtool-5.8.ebuild
new file mode 100644
index 000000000000..49fc0d567fc9
--- /dev/null
+++ b/sys-apps/ethtool/ethtool-5.8.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Utility for examining and tuning ethernet-based network interfaces"
+HOMEPAGE="https://www.kernel.org/pub/software/network/ethtool/"
+SRC_URI="https://www.kernel.org/pub/software/network/ethtool/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+netlink"
+
+DEPEND="app-arch/xz-utils"
+RDEPEND="netlink? ( net-libs/libmnl )"
+
+PATCHES=( "${FILESDIR}/${PN}-5.8-avoid_bashisms.patch" )
+
+src_configure() {
+ econf $(use_enable netlink)
+}