summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-06 20:31:43 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-06 20:36:40 +0100
commitf4cad940e98c5160cf0bb98825dfbd1205199260 (patch)
tree917a638600bd388feafc431962b09dd0ceb968c5 /sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild
parentdev-python/isort-4.3.21_p2: Version bump, add py38, pypy3 (diff)
downloadgentoo-f4cad940e98c5160cf0bb98825dfbd1205199260.tar.gz
gentoo-f4cad940e98c5160cf0bb98825dfbd1205199260.tar.bz2
gentoo-f4cad940e98c5160cf0bb98825dfbd1205199260.zip
sys-apps/gentoo-systemd-integration: Bump to v8
Closes: https://bugs.gentoo.org/651904 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild')
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild
new file mode 100644
index 000000000000..9ad1ea02babe
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-systemd-integration.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+inherit systemd
+
+DESCRIPTION="systemd integration files for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Systemd"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/systemd-207
+ !sys-fs/eudev
+ !sys-fs/udev"
+DEPEND=">=sys-apps/systemd-207
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ [[ ${PV} != 9999 ]] || eautoreconf
+}