summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-04-24 10:40:23 -0400
committerMike Gilbert <floppym@gentoo.org>2022-04-24 10:41:59 -0400
commit65d80628ff6f2a4829b6a904481c52855e85459f (patch)
tree1ff9be53d974a4f8e715118802ad50b1bc7df9f1 /sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild
parentsys-devel/llvm-common: Remove LLVM 11 (diff)
downloadgentoo-65d80628ff6f2a4829b6a904481c52855e85459f.tar.gz
gentoo-65d80628ff6f2a4829b6a904481c52855e85459f.tar.bz2
gentoo-65d80628ff6f2a4829b6a904481c52855e85459f.zip
sys-apps/gentoo-systemd-integration: pass udevdir to configure
The get_udevdir helper function calls pkgconf with PKG_CONFIG_FDO_SYSROOT_RULES set. This is necessary to avoid duplicating SYSROOT in the resulting output. Closes: https://bugs.gentoo.org/840550 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild')
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild
index c2fc5b4077e5..59c33e356cc6 100644
--- a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit systemd
+inherit systemd udev
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-systemd-integration.git"
@@ -35,6 +35,7 @@ src_configure() {
local myconf=(
--with-systemdsystemgeneratordir="$(systemd_get_systemgeneratordir)"
--with-systemdsystempresetdir="$(systemd_get_systempresetdir)"
+ udevdir="${EPREFIX}$(get_udevdir)"
)
econf "${myconf[@]}"
}