summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild')
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild
index c2fc5b4077e5..59c33e356cc6 100644
--- a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit systemd
+inherit systemd udev
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-systemd-integration.git"
@@ -35,6 +35,7 @@ src_configure() {
local myconf=(
--with-systemdsystemgeneratordir="$(systemd_get_systemgeneratordir)"
--with-systemdsystempresetdir="$(systemd_get_systempresetdir)"
+ udevdir="${EPREFIX}$(get_udevdir)"
)
econf "${myconf[@]}"
}