summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-21 01:08:10 +0000
committerSam James <sam@gentoo.org>2022-03-21 01:08:10 +0000
commitd92f9ac9e8850418ae4a10e58a0da2cba0338c07 (patch)
tree017108f548a6c818a9c921fbae301f347d38cf43 /sys-apps/hwdata/hwdata-0.357.ebuild
parentdev-libs/ossp-uuid: use canonical phase ordering (diff)
downloadgentoo-d92f9ac9e8850418ae4a10e58a0da2cba0338c07.tar.gz
gentoo-d92f9ac9e8850418ae4a10e58a0da2cba0338c07.tar.bz2
gentoo-d92f9ac9e8850418ae4a10e58a0da2cba0338c07.zip
sys-apps/hwdata: add 0.357
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/hwdata/hwdata-0.357.ebuild')
-rw-r--r--sys-apps/hwdata/hwdata-0.357.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-apps/hwdata/hwdata-0.357.ebuild b/sys-apps/hwdata/hwdata-0.357.ebuild
new file mode 100644
index 000000000000..6ad75332f251
--- /dev/null
+++ b/sys-apps/hwdata/hwdata-0.357.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Hardware identification and configuration data"
+HOMEPAGE="https://github.com/vcrhonek/hwdata"
+SRC_URI="https://github.com/vcrhonek/hwdata/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+RESTRICT="test"
+
+src_configure() {
+ # configure is not compatible with econf
+ local conf=(
+ ./configure
+ --prefix="${EPREFIX}/usr"
+ --libdir="${EPREFIX}/lib"
+ --datadir="${EPREFIX}/usr/share"
+ )
+ echo "${conf[@]}" >&2
+ "${conf[@]}" || die
+}