summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/hwdata/hwdata-0.357.ebuild')
-rw-r--r--sys-apps/hwdata/hwdata-0.357.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-apps/hwdata/hwdata-0.357.ebuild b/sys-apps/hwdata/hwdata-0.357.ebuild
new file mode 100644
index 000000000000..6ad75332f251
--- /dev/null
+++ b/sys-apps/hwdata/hwdata-0.357.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Hardware identification and configuration data"
+HOMEPAGE="https://github.com/vcrhonek/hwdata"
+SRC_URI="https://github.com/vcrhonek/hwdata/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+RESTRICT="test"
+
+src_configure() {
+ # configure is not compatible with econf
+ local conf=(
+ ./configure
+ --prefix="${EPREFIX}/usr"
+ --libdir="${EPREFIX}/lib"
+ --datadir="${EPREFIX}/usr/share"
+ )
+ echo "${conf[@]}" >&2
+ "${conf[@]}" || die
+}