summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2021-03-18 00:26:05 +0000
committerJason Zaman <perfinion@gentoo.org>2021-04-02 21:15:28 -0700
commit290a68c7ccea5267f465691b82b6552e13a8aa37 (patch)
tree0a3d56b2ed001f7d387eb4fa47eba28d0358bad9 /sys-apps/semodule-utils/semodule-utils-3.2.ebuild
parentsys-apps/selinux-python: Sync live ebuild. (diff)
downloadgentoo-290a68c7ccea5267f465691b82b6552e13a8aa37.tar.gz
gentoo-290a68c7ccea5267f465691b82b6552e13a8aa37.tar.bz2
gentoo-290a68c7ccea5267f465691b82b6552e13a8aa37.zip
sys-apps/semodule-utils: Version updated to 3.2.
Signed-off-by: Jonathan Davies <jpds@protonmail.com> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-apps/semodule-utils/semodule-utils-3.2.ebuild')
-rw-r--r--sys-apps/semodule-utils/semodule-utils-3.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/semodule-utils/semodule-utils-3.2.ebuild b/sys-apps/semodule-utils/semodule-utils-3.2.ebuild
new file mode 100644
index 000000000000..13fc0d86279e
--- /dev/null
+++ b/sys-apps/semodule-utils/semodule-utils-3.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+fi
+
+DESCRIPTION="SELinux policy module utilities"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libsepol-${PV}:="
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}