summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-09-17 23:21:24 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-09-18 00:37:21 +0200
commite6c9a95b321bf8e7af34d29eca9a1a7299193c6f (patch)
treeca950554a172b2548e5f7a7e5e9c7746ded440bb /sys-apps/system-monitoring-center/system-monitoring-center-2.22.1.ebuild
parentsys-kernel/git-sources: add 6.6_rc2 (diff)
downloadgentoo-e6c9a95b321bf8e7af34d29eca9a1a7299193c6f.tar.gz
gentoo-e6c9a95b321bf8e7af34d29eca9a1a7299193c6f.tar.bz2
gentoo-e6c9a95b321bf8e7af34d29eca9a1a7299193c6f.zip
sys-apps/system-monitoring-center: bump to 2.22.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sys-apps/system-monitoring-center/system-monitoring-center-2.22.1.ebuild')
-rw-r--r--sys-apps/system-monitoring-center/system-monitoring-center-2.22.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/system-monitoring-center/system-monitoring-center-2.22.1.ebuild b/sys-apps/system-monitoring-center/system-monitoring-center-2.22.1.ebuild
new file mode 100644
index 000000000000..0d57d2200134
--- /dev/null
+++ b/sys-apps/system-monitoring-center/system-monitoring-center-2.22.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit meson python-single-r1 xdg
+
+DESCRIPTION="Multi-featured system monitor GUI written in Python"
+HOMEPAGE="https://github.com/hakandundar34coding/system-monitoring-center/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hakandundar34coding/${PN}.git"
+else
+ SRC_URI="https://github.com/hakandundar34coding/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ gui-libs/gtk:4[introspection]
+ gui-libs/libadwaita:1
+ sys-apps/dmidecode
+ sys-apps/hwdata
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+
+src_install() {
+ meson_src_install
+ python_optimize "${ED}"/usr/share/${PN}
+
+ mv "${ED}"/usr/share/appdata "${ED}"/usr/share/metainfo || die
+}