summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-04-01 18:17:53 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-04-01 18:18:06 +0200
commitdb91656281fd561a091f2659553026e7aa804455 (patch)
treed3103a6b5a99e5fb848acc27cc003162bd078228 /sys-auth/AusweisApp2/AusweisApp2-1.22.2.ebuild
parentdev-lua/luarocks: bump to version 3.6.0 (diff)
downloadgentoo-db91656281fd561a091f2659553026e7aa804455.tar.gz
gentoo-db91656281fd561a091f2659553026e7aa804455.tar.bz2
gentoo-db91656281fd561a091f2659553026e7aa804455.zip
sys-auth/AusweisApp2: bump to version 1.22.2
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-auth/AusweisApp2/AusweisApp2-1.22.2.ebuild')
-rw-r--r--sys-auth/AusweisApp2/AusweisApp2-1.22.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-auth/AusweisApp2/AusweisApp2-1.22.2.ebuild b/sys-auth/AusweisApp2/AusweisApp2-1.22.2.ebuild
new file mode 100644
index 000000000000..1a14a298ba88
--- /dev/null
+++ b/sys-auth/AusweisApp2/AusweisApp2-1.22.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+SRC_URI="https://github.com/Governikus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebsockets:5[qml]
+ dev-qt/qtwidgets:5
+ net-libs/http-parser:0=
+ sys-apps/pcsc-lite
+ virtual/udev"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=OFF )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}