summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-20 04:05:09 +0000
committerSam James <sam@gentoo.org>2022-11-20 04:05:25 +0000
commitfbe8861b0c541ee7fabc1c196d414450906575a6 (patch)
treedb60b84971561e1c390e8172fbf9e61f916383aa /sys-auth/munge/munge-0.5.15.ebuild
parentdev-lang/php: Set max openssl version on 7.4 and 8.0 slots (diff)
downloadgentoo-fbe8861b0c541ee7fabc1c196d414450906575a6.tar.gz
gentoo-fbe8861b0c541ee7fabc1c196d414450906575a6.tar.bz2
gentoo-fbe8861b0c541ee7fabc1c196d414450906575a6.zip
sys-auth/munge: restore tmpfiles
Upstream dropped it apart from for CentOS 7, but let's keep it as it's easier than trying to handle in init scripts. Closes: https://bugs.gentoo.org/881781 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-auth/munge/munge-0.5.15.ebuild')
-rw-r--r--sys-auth/munge/munge-0.5.15.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys-auth/munge/munge-0.5.15.ebuild b/sys-auth/munge/munge-0.5.15.ebuild
index 475278514dd8..885f7c485398 100644
--- a/sys-auth/munge/munge-0.5.15.ebuild
+++ b/sys-auth/munge/munge-0.5.15.ebuild
@@ -78,11 +78,13 @@ src_install() {
newconfd "$(prefixify_ro "${FILESDIR}"/${PN}d.confd)" ${PN}d
newinitd "$(prefixify_ro "${FILESDIR}"/${PN}d.initd)" ${PN}d
+ newtmpfiles "${FILESDIR}"/munged.tmpfiles.conf munged.conf
+
if ! use static-libs; then
find "${ED}" -name '*.la' -delete || die
fi
}
pkg_postinst() {
- tmpfiles_process munge.conf
+ tmpfiles_process munged.conf
}