summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-11-12 11:59:48 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-11-12 13:07:55 -0800
commit381c8330770d424a37f1f8800e5d0075c578e612 (patch)
tree88a4275987a9115067a897ec3f9acd55de7e1937 /sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2-r1.ebuild
parentmedia-libs/fontconfig: stable 2.13.0-r4 for hppa, bug #664108 (diff)
downloadgentoo-381c8330770d424a37f1f8800e5d0075c578e612.tar.gz
gentoo-381c8330770d424a37f1f8800e5d0075c578e612.tar.bz2
gentoo-381c8330770d424a37f1f8800e5d0075c578e612.zip
sys-boot/plymouth-openrc-plugin: EAPI revbump, fixes
Add patch fixing early exit which prevented showing splash on reboot. EAPI 4->7 Fix license, it clearly says GPL-2 or later. Touch up ebuild. While this package is no longer developed it still works fine, and especially useful at fixing weird plymouth behaviour on boot under openrc. Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2-r1.ebuild')
-rw-r--r--sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2-r1.ebuild b/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..a073ee75df03
--- /dev/null
+++ b/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Plymouth plugin for OpenRC"
+HOMEPAGE="https://github.com/aidecoe/plymouth-openrc-plugin"
+SRC_URI="https://dev.gentoo.org/~aidecoe/distfiles/${CATEGORY}/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-apps/openrc:="
+RDEPEND="${DEPEND}
+ sys-boot/plymouth"
+
+PATCHES=( "${FILESDIR}/${P}-exit-at-mount-ro.patch" )
+
+src_install() {
+ insinto /$(get_libdir)/rc/plugins
+ doins plymouth.so
+}
+
+pkg_postinst() {
+ ewarn "You need to disable 'rc_interactive' feature in /etc/rc.conf to make"
+ ewarn "Plymouth work properly with OpenRC init system."
+
+ if has_version sys-apps/systemd; then
+ eerror "sys-apps/systemd is installed, please uninstall this package if you"
+ eerror "are booting with systemd"
+ fi
+}