summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2022-02-07 14:17:58 -0600
committerSam James <sam@gentoo.org>2022-02-09 11:23:36 +0000
commit5872ad7b37126df3e8897f3db41e3853e6840d99 (patch)
tree704bd6ac5703b841df0d0bf9f6bbcbf45118a17f /sys-boot
parentprofile/features/musl: mask net-misc/netkit-telnetd (diff)
downloadgentoo-5872ad7b37126df3e8897f3db41e3853e6840d99.tar.gz
gentoo-5872ad7b37126df3e8897f3db41e3853e6840d99.tar.bz2
gentoo-5872ad7b37126df3e8897f3db41e3853e6840d99.zip
sys-boot/tboot: Die if tc-is-clang. Requires VLAIS which is gcc-only.
Closes: https://bugs.gentoo.org/832020 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24119 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/tboot/tboot-1.10.3.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/sys-boot/tboot/tboot-1.10.3.ebuild b/sys-boot/tboot/tboot-1.10.3.ebuild
index cdb682a949ff..4cedba3fabfc 100644
--- a/sys-boot/tboot/tboot-1.10.3.ebuild
+++ b/sys-boot/tboot/tboot-1.10.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -28,6 +28,16 @@ PATCHES=( "${FILESDIR}/${PN}-1.10.3-disable-Werror.patch"
"${FILESDIR}/${PN}-1.10.3-disable-strip.patch"
"${FILESDIR}/${PN}-1.10.3-dont-call-toolchain-directly.patch" )
+pkg_setup() {
+ if tc-is-clang; then
+ eerror "tboot is a freestanding application that uses gcc"
+ eerror "extensions in fundemental ways, include VLAIS"
+ eerror "(Variable Length Arrays in Structs) and will not"
+ eerror "compile with clang witout upstream action"
+ die "Cannot compile with clang. See bug #832020"
+ fi
+}
+
src_configure() {
tc-export AS LD CC CPP AR RANLIB NM OBJCOPY OBJDUMP STRIP