summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-12-25 22:31:44 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-12-25 22:31:44 +0000
commit7d2ecca393148ac30882815ade02c4a8e2308dff (patch)
tree7dffae362f9fbcc4910177d249bcdae25ef823b7 /sys-boot
parentsys-boot/silo: fix USE=tilo-only, honot CC (diff)
downloadgentoo-7d2ecca393148ac30882815ade02c4a8e2308dff.tar.gz
gentoo-7d2ecca393148ac30882815ade02c4a8e2308dff.tar.bz2
gentoo-7d2ecca393148ac30882815ade02c4a8e2308dff.zip
sys-boot/silo: fix src_instal()
Due to missing trailing '\' all arguments to `emake` were ignored. Bug: https://bugs.gentoo.org/759655 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/silo/silo-1.4.14_p20200602.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-boot/silo/silo-1.4.14_p20200602.ebuild b/sys-boot/silo/silo-1.4.14_p20200602.ebuild
index 42f7fc372543..6e6b9cd4d3f2 100644
--- a/sys-boot/silo/silo-1.4.14_p20200602.ebuild
+++ b/sys-boot/silo/silo-1.4.14_p20200602.ebuild
@@ -42,7 +42,7 @@ _emake() {
STRIP="$(tc-getSTRIP)" \
NM="$(tc-getNM)" \
LD="$(tc-getLD) -m elf32_sparc" \
- TILO_ONLY=$(usex tilo-only yes no)
+ TILO_ONLY=$(usex tilo-only yes no) \
\
"$@"
}
@@ -50,7 +50,7 @@ _emake() {
src_compile() {
filter-flags "-fstack-protector"
- _emake $(usex tilo-only '-C tilo' '')
+ _emake
}
src_install() {