summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2024-02-07 00:17:37 +0000
committerSam James <sam@gentoo.org>2024-02-11 13:35:35 +0000
commitdd927e4ede05c4b468fa778b8ddf83ae7e8ce297 (patch)
treebfa20671d2582d89be654e0f765d0848f326ba3e /sys-devel/clang-common/clang-common-19.0.0_pre20240203.ebuild
parentnet-dns/rbldnsd: define USE=ipv6 locally to avoid a pkgcheck warning (diff)
downloadgentoo-dd927e4ede05c4b468fa778b8ddf83ae7e8ce297.tar.gz
gentoo-dd927e4ede05c4b468fa778b8ddf83ae7e8ce297.tar.bz2
gentoo-dd927e4ede05c4b468fa778b8ddf83ae7e8ce297.zip
sys-devel/clang-common: fixes for darwin
Add keywords, remove unsupported linker option Bug: https://bugs.gentoo.org/758167 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/clang-common/clang-common-19.0.0_pre20240203.ebuild')
-rw-r--r--sys-devel/clang-common/clang-common-19.0.0_pre20240203.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/sys-devel/clang-common/clang-common-19.0.0_pre20240203.ebuild b/sys-devel/clang-common/clang-common-19.0.0_pre20240203.ebuild
index a50679150043..80d989986d28 100644
--- a/sys-devel/clang-common/clang-common-19.0.0_pre20240203.ebuild
+++ b/sys-devel/clang-common/clang-common-19.0.0_pre20240203.ebuild
@@ -174,11 +174,18 @@ src_install() {
-include "${EPREFIX}/usr/include/gentoo/fortify.h"
EOF
- newins - gentoo-hardened-ld.cfg <<-EOF
- # Some of these options are added unconditionally, regardless of
- # USE=hardened, for parity with sys-devel/gcc.
- -Wl,-z,relro
- EOF
+ if use kernel_Darwin; then
+ newins - gentoo-hardened-ld.cfg <<-EOF
+ # There was -Wl,-z,relro here, but it's not supported on Mac
+ # TODO: investigate whether -bind_at_load or -read_only_stubs will do the job
+ EOF
+ else
+ newins - gentoo-hardened-ld.cfg <<-EOF
+ # Some of these options are added unconditionally, regardless of
+ # USE=hardened, for parity with sys-devel/gcc.
+ -Wl,-z,relro
+ EOF
+ fi
dodir /usr/include/gentoo