summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/clang-common/clang-common-19.0.0_pre20240203.ebuild')
-rw-r--r--sys-devel/clang-common/clang-common-19.0.0_pre20240203.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/sys-devel/clang-common/clang-common-19.0.0_pre20240203.ebuild b/sys-devel/clang-common/clang-common-19.0.0_pre20240203.ebuild
index a50679150043..80d989986d28 100644
--- a/sys-devel/clang-common/clang-common-19.0.0_pre20240203.ebuild
+++ b/sys-devel/clang-common/clang-common-19.0.0_pre20240203.ebuild
@@ -174,11 +174,18 @@ src_install() {
-include "${EPREFIX}/usr/include/gentoo/fortify.h"
EOF
- newins - gentoo-hardened-ld.cfg <<-EOF
- # Some of these options are added unconditionally, regardless of
- # USE=hardened, for parity with sys-devel/gcc.
- -Wl,-z,relro
- EOF
+ if use kernel_Darwin; then
+ newins - gentoo-hardened-ld.cfg <<-EOF
+ # There was -Wl,-z,relro here, but it's not supported on Mac
+ # TODO: investigate whether -bind_at_load or -read_only_stubs will do the job
+ EOF
+ else
+ newins - gentoo-hardened-ld.cfg <<-EOF
+ # Some of these options are added unconditionally, regardless of
+ # USE=hardened, for parity with sys-devel/gcc.
+ -Wl,-z,relro
+ EOF
+ fi
dodir /usr/include/gentoo