summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-10 15:04:52 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-10 15:05:46 +0100
commit43ba0dabac8afb4fc205e5282f3eb42935408854 (patch)
treea347cfcbde5684cd562898fe7798c5fc7e8495bf /sys-devel/llvm
parentdev-ada/gnatmem: Add ~x86 (diff)
downloadgentoo-43ba0dabac8afb4fc205e5282f3eb42935408854.tar.gz
gentoo-43ba0dabac8afb4fc205e5282f3eb42935408854.tar.bz2
gentoo-43ba0dabac8afb4fc205e5282f3eb42935408854.zip
sys-devel/llvm: Temporarily refuse to build w/ GCC-7 due to hangs
Bug: https://bugs.gentoo.org/649880
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/llvm-6.0.0.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/sys-devel/llvm/llvm-6.0.0.ebuild b/sys-devel/llvm/llvm-6.0.0.ebuild
index e474af58c92d..f38524606bb8 100644
--- a/sys-devel/llvm/llvm-6.0.0.ebuild
+++ b/sys-devel/llvm/llvm-6.0.0.ebuild
@@ -75,6 +75,15 @@ S=${WORKDIR}/${P/_/}.src
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
+pkg_pretend() {
+ if tc-is-gcc && [[ $(gcc-major-version) -ge 7 ]]; then
+ eerror "GCC 7 is known to cause mis-compilation that causes the build to hang."
+ eerror "Please use an older version to build LLVM until a good solution is found."
+ eerror "Bug report: https://bugs.gentoo.org/649880"
+ die "GCC-7+ is not supported"
+ fi
+}
+
src_prepare() {
# Fix llvm-config for shared linking and sane flags
# https://bugs.gentoo.org/show_bug.cgi?id=565358