summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-25 01:35:58 +0100
committerSam James <sam@gentoo.org>2022-05-26 06:48:02 +0100
commit168e3783ac7ee8d1fd40e43cb9a0debc5585148a (patch)
tree1e667aaca6aabf3bf40408c4d3124197014861ad /sys-devel
parentsys-devel/binutils: use econf; sync from live (diff)
downloadgentoo-168e3783ac7ee8d1fd40e43cb9a0debc5585148a.tar.gz
gentoo-168e3783ac7ee8d1fd40e43cb9a0debc5585148a.tar.bz2
gentoo-168e3783ac7ee8d1fd40e43cb9a0debc5585148a.zip
sys-devel/binutils-hppa64: use econf
Sync more with binutils-libs by using econf instead of raw ./configure call; means we benefit from some of the default arguments it passes, in particular thinking of silent rules which upstream are starting to support more now too (and enable by default) which econf disables. Also, we use it fine in binutils-libs w/o issue. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils-hppa64/binutils-hppa64-2.38-r2.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/sys-devel/binutils-hppa64/binutils-hppa64-2.38-r2.ebuild b/sys-devel/binutils-hppa64/binutils-hppa64-2.38-r2.ebuild
index abe6f85f3a2b..cfb3450416da 100644
--- a/sys-devel/binutils-hppa64/binutils-hppa64-2.38-r2.ebuild
+++ b/sys-devel/binutils-hppa64/binutils-hppa64-2.38-r2.ebuild
@@ -70,19 +70,19 @@ BDEPEND="
RESTRICT="!test? ( test )"
-MY_BUILDDIR=${WORKDIR}/build
-S=${WORKDIR}/${P/-hppa64/}
+MY_BUILDDIR="${WORKDIR}"/build
+S="${WORKDIR}"/${P/-hppa64/}
src_unpack() {
if [[ ${PV} == 9999* ]] ; then
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/toolchain/binutils-patches.git"
- EGIT_CHECKOUT_DIR=${WORKDIR}/patches-git
+ EGIT_CHECKOUT_DIR="${WORKDIR}"/patches-git
git-r3_src_unpack
mv patches-git/9999 patch || die
+ S="${WORKDIR}"/binutils
EGIT_REPO_URI="https://sourceware.org/git/binutils-gdb.git"
- S=${WORKDIR}/binutils
- EGIT_CHECKOUT_DIR=${S}
+ EGIT_CHECKOUT_DIR="${S}"
git-r3_src_unpack
else
unpack ${P/-hppa64/}.tar.xz
@@ -94,7 +94,7 @@ src_unpack() {
local dir=${P%_p?}
dir=${dir/-hppa64/}
- S=${WORKDIR}/${dir}
+ S="${WORKDIR}"/${dir}
fi
cd "${WORKDIR}" || die
@@ -178,7 +178,7 @@ src_configure() {
done
echo
- cd "${MY_BUILDDIR}"
+ cd "${MY_BUILDDIR}" || die
local myconf=()
if use plugins ; then
@@ -251,7 +251,6 @@ src_configure() {
--with-bugurl="$(toolchain-binutils_bugurl)"
--with-pkgversion="$(toolchain-binutils_pkgversion)"
$(use_enable static-libs static)
- ${EXTRA_ECONF}
# Disable modules that are in a combined binutils/gdb tree. bug #490566
--disable-{gdb,libdecnumber,readline,sim}
# Strip out broken static link flags.
@@ -281,8 +280,7 @@ src_configure() {
fi
fi
- echo ./configure "${myconf[@]}"
- "${S}"/configure "${myconf[@]}" || die
+ ECONF_SOURCE="${S}" econf "${myconf[@]}" || die
# Prevent makeinfo from running if doc is unset.
if ! use doc ; then
@@ -309,7 +307,7 @@ src_compile() {
}
src_test() {
- cd "${MY_BUILDDIR}"
+ cd "${MY_BUILDDIR}" || die
# bug #637066
filter-flags -Wall -Wreturn-type