summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-04-08 08:42:55 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-04-08 08:43:28 +0100
commit1bfb04cfc33d12fc397e37f1f1339902e3f3251e (patch)
tree91b4d1141ec83a672b83a5ba1189089187b18a4e /sys-devel
parentnet-fs/netatalk-3.1.2: fix compilation due to my_bool, bug #692560 (diff)
downloadgentoo-1bfb04cfc33d12fc397e37f1f1339902e3f3251e.tar.gz
gentoo-1bfb04cfc33d12fc397e37f1f1339902e3f3251e.tar.bz2
gentoo-1bfb04cfc33d12fc397e37f1f1339902e3f3251e.zip
sys-devel/gdb: use ${CHOST}-pkg-config, bug #716558
When cross-compiling gdb ./configure found CBUILD's dev-util/source-highlight. That is never correct as client is supposed to be running on CHOST. The change switches to CHOST's PKG_CONFIG. Reported-by: Jan Postránský Bug: https://bugs.gentoo.org/716558 Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gdb/gdb-9.1.ebuild5
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/sys-devel/gdb/gdb-9.1.ebuild b/sys-devel/gdb/gdb-9.1.ebuild
index 85e667269711..9361fca6fb0c 100644
--- a/sys-devel/gdb/gdb-9.1.ebuild
+++ b/sys-devel/gdb/gdb-9.1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python{3_6,3_7} )
-inherit eutils flag-o-matic python-single-r1
+inherit eutils flag-o-matic python-single-r1 toolchain-funcs
export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
@@ -183,6 +183,9 @@ src_configure() {
myconf+=( --disable-largefile )
fi
+ # source-highlight is detected with pkg-config: bug #716558
+ export ac_cv_path_pkg_config_prog_path="$(tc-getPKG_CONFIG)"
+
mkdir "${GDB_BUILD_DIR}" || die
pushd "${GDB_BUILD_DIR}" || die
ECONF_SOURCE=${S}
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index 9e181d9e64bf..056b99bbc890 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python{3_6,3_7} )
-inherit eutils flag-o-matic python-single-r1
+inherit eutils flag-o-matic python-single-r1 toolchain-funcs
export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
@@ -181,6 +181,9 @@ src_configure() {
myconf+=( --disable-largefile )
fi
+ # source-highlight is detected with pkg-config: bug #716558
+ export ac_cv_path_pkg_config_prog_path="$(tc-getPKG_CONFIG)"
+
econf "${myconf[@]}"
}