summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2016-06-29 17:17:07 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2016-06-30 01:31:15 +0300
commit78687b7871a6d19ba23ac5da91c72d9732061bc1 (patch)
treebefa090ead56292b47a1607c1388583318fbbc3e /sys-fabric/srptools
parentgames-emulation/dosbox: sync live ebuild and make it copyable (diff)
downloadgentoo-78687b7871a6d19ba23ac5da91c72d9732061bc1.tar.gz
gentoo-78687b7871a6d19ba23ac5da91c72d9732061bc1.tar.bz2
gentoo-78687b7871a6d19ba23ac5da91c72d9732061bc1.zip
eclass/openib.eclass: Clean up ancient versions
Also move to sys-fabric category
Diffstat (limited to 'sys-fabric/srptools')
-rw-r--r--sys-fabric/srptools/Manifest2
-rw-r--r--sys-fabric/srptools/files/srpd.initd42
-rw-r--r--sys-fabric/srptools/metadata.xml14
-rw-r--r--sys-fabric/srptools/srptools-0.0.4-r2.ebuild30
-rw-r--r--sys-fabric/srptools/srptools-1.0.2.ebuild29
5 files changed, 117 insertions, 0 deletions
diff --git a/sys-fabric/srptools/Manifest b/sys-fabric/srptools/Manifest
new file mode 100644
index 000000000000..ca457c585395
--- /dev/null
+++ b/sys-fabric/srptools/Manifest
@@ -0,0 +1,2 @@
+DIST OFED-3.12-rc1.tgz 22055476 SHA256 14ca8a2b0d68e3ee9a37f475fa9eecd9a5ffd6055135f9d4d9db8319843a94dc SHA512 9f834d6982ab7e8ab47a8b5c958ab2e4c238ef983e47798e7f06655f69672ea1e996297939b381f26ed8c39552f6e62156173d5ddd2f0a7b6cad6aecdd973944 WHIRLPOOL 5a64b1d952890ea0e72e0ca93654a0fabc8f871475b05fcbe3b214ddfe4836f6b92d4fbc9e0f0d79acfe69d8c8d219b2c467c23654021e23eaf85ae6825ea4a9
+DIST OFED-3.5-rc2.tgz 18600237 SHA256 b267cea49bf72790843e6b08e26c10a6954d7736a8b93deed1e632772f4f5fff SHA512 deb83c3417ac60bd5d4c6ac1cadf93d6a34a55ca58365b54bb0c3a8230ba6a7f13e0257515dac0170cc4ab46b558519c86e6c01f7fa49550162feed0b0ea2e89 WHIRLPOOL e6843593fbe4937ffcf600be9cb3dee78e14cbeb4c411a4b64076b1194653cbcb9d4bc6cbd52ad77ac9c6b14d4dd2cdafa4364bfe6924b55896844042aa4d9cd
diff --git a/sys-fabric/srptools/files/srpd.initd b/sys-fabric/srptools/files/srpd.initd
new file mode 100644
index 000000000000..d386df8396ac
--- /dev/null
+++ b/sys-fabric/srptools/files/srpd.initd
@@ -0,0 +1,42 @@
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+description="SCSI RDMA Protoaemon daemon"
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if ! modinfo ib_srp > /dev/null 2>&1 ; then
+ eerror "ib_srp module not found!"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig
+ ebegin "Loading ib_srp module"
+ modprobe ib_srp
+ eend $?
+ ebegin "Starting srp_daemon"
+ start-stop-daemon \
+ --start \
+ --background \
+ --make-pidfile \
+ --pidfile ${SRP_DAEMON_PID:-/var/run/srpd.pid} \
+ --exec /usr/sbin/srp_daemon -- ${SRP_DAEMON_OPTS:- -e -R 60}
+ eend $?
+
+}
+
+stop() {
+ ebegin "Stopping srp_daemon"
+ start-stop-daemon --stop --pidfile ${SRP_DAEMON_PID:-/var/run/srpd.pid}
+ eend $?
+ ebegin "Unloading ib_srp module"
+ rmmod ib_srp
+ eend $?
+}
diff --git a/sys-fabric/srptools/metadata.xml b/sys-fabric/srptools/metadata.xml
new file mode 100644
index 000000000000..785fc5394edb
--- /dev/null
+++ b/sys-fabric/srptools/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cluster@gentoo.org</email>
+ <name>Gentoo Cluster Project</name>
+ </maintainer>
+ <longdescription>
+srptools is a package of tools for discovering and connecting to SRP
+SCSI targets on InfiniBand fabrics. These targets can be accessed
+with the InfiniBand SRP initiator module, "ib_srp," included in Linux
+kernels 2.6.15 and newer.
+</longdescription>
+</pkgmetadata>
diff --git a/sys-fabric/srptools/srptools-0.0.4-r2.ebuild b/sys-fabric/srptools/srptools-0.0.4-r2.ebuild
new file mode 100644
index 000000000000..da45e738e556
--- /dev/null
+++ b/sys-fabric/srptools/srptools-0.0.4-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+OFED_VER="3.5"
+OFED_RC="1"
+OFED_RC_VER="2"
+OFED_SUFFIX="0.1.gce1f64c"
+OFED_SNAPSHOT="1"
+
+inherit openib
+
+DESCRIPTION="Tools for discovering and connecting to SRP CSI targets on InfiniBand fabrics"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+DEPEND="
+ sys-fabric/libibverbs:${SLOT}
+ sys-fabric/libibumad:${SLOT}
+ "
+RDEPEND="${DEPEND}"
+block_other_ofed_versions
+
+src_install() {
+ default
+ newinitd "${FILESDIR}/srpd.initd" srpd
+}
diff --git a/sys-fabric/srptools/srptools-1.0.2.ebuild b/sys-fabric/srptools/srptools-1.0.2.ebuild
new file mode 100644
index 000000000000..2de71bc03263
--- /dev/null
+++ b/sys-fabric/srptools/srptools-1.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+OFED_VER="3.12"
+OFED_RC="1"
+OFED_RC_VER="1"
+OFED_SUFFIX="1"
+
+inherit openib
+
+DESCRIPTION="Tools for discovering and connecting to SRP CSI targets on InfiniBand fabrics"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+DEPEND="
+ sys-fabric/libibverbs:${SLOT}
+ sys-fabric/libibumad:${SLOT}
+ "
+RDEPEND="${DEPEND}"
+block_other_ofed_versions
+
+src_install() {
+ default
+ newinitd "${FILESDIR}/srpd.initd" srpd
+}