summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-20 17:21:06 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-20 17:21:06 +0200
commit339cd2fbceb72e5a41f149efee1661d6ac0bc60c (patch)
tree9f7a4cc2c4130ccb0627682693a931bf88a23b38 /sys-fs/cramfs/cramfs-2.1.ebuild
parentsys-apps/cciss_vol_status: bump to v1.12a (diff)
downloadgentoo-339cd2fbceb72e5a41f149efee1661d6ac0bc60c.tar.gz
gentoo-339cd2fbceb72e5a41f149efee1661d6ac0bc60c.tar.bz2
gentoo-339cd2fbceb72e5a41f149efee1661d6ac0bc60c.zip
sys-fs/cramfs: bump to v2.1
Switched to (new) upstream on GitHub. Package-Manager: Portage-3.0.3, Repoman-3.0.0 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-fs/cramfs/cramfs-2.1.ebuild')
-rw-r--r--sys-fs/cramfs/cramfs-2.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-fs/cramfs/cramfs-2.1.ebuild b/sys-fs/cramfs/cramfs-2.1.ebuild
new file mode 100644
index 000000000000..856b3d1d26ae
--- /dev/null
+++ b/sys-fs/cramfs/cramfs-2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux filesystem designed to be simple, small, and to compress things well"
+HOMEPAGE="https://github.com/npitre/cramfs-tools"
+SRC_URI="https://github.com/npitre/cramfs-tools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-libs/zlib:="
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/cramfs-tools-${PV}"
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ into /
+ dosbin mkcramfs cramfsck
+ dodoc README NOTES
+}