summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/cramfs/cramfs-2.1.ebuild')
-rw-r--r--sys-fs/cramfs/cramfs-2.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-fs/cramfs/cramfs-2.1.ebuild b/sys-fs/cramfs/cramfs-2.1.ebuild
new file mode 100644
index 000000000000..856b3d1d26ae
--- /dev/null
+++ b/sys-fs/cramfs/cramfs-2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux filesystem designed to be simple, small, and to compress things well"
+HOMEPAGE="https://github.com/npitre/cramfs-tools"
+SRC_URI="https://github.com/npitre/cramfs-tools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-libs/zlib:="
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/cramfs-tools-${PV}"
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ into /
+ dosbin mkcramfs cramfsck
+ dodoc README NOTES
+}