summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Joldasov <bratishkaerik@getgoogleoff.me>2022-11-07 20:40:33 +0600
committerSam James <sam@gentoo.org>2022-11-08 04:07:59 +0000
commitc91927b57a644d3625554a9506239e7d5a230771 (patch)
tree341ec2c30b27359f8a7a712b90f8ce1f4983322a /sys-fs/ncdu/ncdu-2.2.1.ebuild
parentsys-fs/ncdu-bin: add 2.2.1 (diff)
downloadgentoo-c91927b57a644d3625554a9506239e7d5a230771.tar.gz
gentoo-c91927b57a644d3625554a9506239e7d5a230771.tar.bz2
gentoo-c91927b57a644d3625554a9506239e7d5a230771.zip
sys-fs/ncdu: add 2.2.1
Signed-off-by: Eric Joldasov <bratishkaerik@getgoogleoff.me> Closes: https://github.com/gentoo/gentoo/pull/28178 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs/ncdu/ncdu-2.2.1.ebuild')
-rw-r--r--sys-fs/ncdu/ncdu-2.2.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-fs/ncdu/ncdu-2.2.1.ebuild b/sys-fs/ncdu/ncdu-2.2.1.ebuild
new file mode 100644
index 000000000000..ee095fee9c6f
--- /dev/null
+++ b/sys-fs/ncdu/ncdu-2.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="NCurses Disk Usage"
+HOMEPAGE="https://dev.yorhel.nl/ncdu/"
+SRC_URI="
+ https://dev.yorhel.nl/download/${P}.tar.gz
+ https://codeberg.org/BratishkaErik/distfiles/media/branch/master/${P}-upstream-zig-0.10-updates-r1.patch
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${DISTDIR}/${P}-upstream-zig-0.10-updates-r1.patch"
+)
+
+DEPEND="sys-libs/ncurses:=[unicode(+)]"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ || ( ~dev-lang/zig-0.10.0 ~dev-lang/zig-bin-0.10.0 )
+ virtual/pkgconfig
+"
+
+# see https://github.com/ziglang/zig/issues/3382
+# For now, Zig doesn't support CFLAGS/LDFLAGS/etc.
+QA_FLAGS_IGNORED="usr/bin/ncdu"
+
+src_test() {
+ zig build test || die "Tests failed"
+}
+
+src_install() {
+ emake PREFIX="${ED}"/usr install
+
+ dodoc README.md ChangeLog
+}