summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-12-20 22:34:07 +0100
committerDavid Seifert <soap@gentoo.org>2016-12-20 22:34:07 +0100
commitdad0ac9a3fe3d4a2ad54b8e31e74cc6101ce78dc (patch)
tree1f5746992c4ee291c91edc4301e198a939e7b5c6 /sys-fs/squashfs-tools/squashfs-tools-4.3-r1.ebuild
parentprofiles: Mask net-analyzer/snips for removal (diff)
downloadgentoo-dad0ac9a3fe3d4a2ad54b8e31e74cc6101ce78dc.tar.gz
gentoo-dad0ac9a3fe3d4a2ad54b8e31e74cc6101ce78dc.tar.bz2
gentoo-dad0ac9a3fe3d4a2ad54b8e31e74cc6101ce78dc.zip
sys-fs/squashfs-tools: Fix building with GCC 5
Gentoo-bug: 595290 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-fs/squashfs-tools/squashfs-tools-4.3-r1.ebuild')
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-4.3-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.3-r1.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.3-r1.ebuild
index 9a3ccd0b8143..19db0eb6a84f 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-4.3-r1.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-4.3-r1.ebuild
@@ -4,7 +4,7 @@
EAPI="5"
-inherit eutils toolchain-funcs
+inherit eutils flag-o-matic toolchain-funcs
DEB_VER="3"
@@ -40,6 +40,10 @@ src_prepare() {
use10() { usex $1 1 0 ; }
src_configure() {
+ # restore GNU89 inline semantics to
+ # emit function symbols, bug 595290
+ append-cflags -std=gnu89
+
# set up make command line variables in EMAKE_SQUASHFS_CONF
EMAKE_SQUASHFS_CONF=(
LZMA_XZ_SUPPORT=$(use10 lzma)