summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-05-11 23:46:57 -0500
committerTim Harder <radhermit@gentoo.org>2019-05-11 23:51:41 -0500
commitc5d7c6ec03977059ad585b4cefe6a1c8ca9766f6 (patch)
treead1c40d6edeefb2d02abba3e7abc34eb475f8481 /sys-fs
parentsys-fs/rar2fs: fix build with newer unrar that drops static libs (diff)
downloadgentoo-c5d7c6ec03977059ad585b4cefe6a1c8ca9766f6.tar.gz
gentoo-c5d7c6ec03977059ad585b4cefe6a1c8ca9766f6.tar.bz2
gentoo-c5d7c6ec03977059ad585b4cefe6a1c8ca9766f6.zip
sys-fs/rar2fs: remove old
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/rar2fs/Manifest1
-rw-r--r--sys-fs/rar2fs/rar2fs-1.27.1.ebuild26
-rw-r--r--sys-fs/rar2fs/rar2fs-1.27.2.ebuild27
3 files changed, 0 insertions, 54 deletions
diff --git a/sys-fs/rar2fs/Manifest b/sys-fs/rar2fs/Manifest
index 8a1e77971366..ccc6e5e7bd61 100644
--- a/sys-fs/rar2fs/Manifest
+++ b/sys-fs/rar2fs/Manifest
@@ -1,2 +1 @@
-DIST rar2fs-1.27.1.tar.gz 260012 BLAKE2B 71f308827e33a32b5cda7d30d92147fe435eb09f914f50a7d7917ace18131a8d6b2568f50eaeedcaf2e19c66559666f67665f8ef7f475f57bb17032845c87159 SHA512 c31bc00e532192baa1faeaffa484306e13c1c4110677ae6235048087637a8af2f604ded9cfdec9889d9c5cb099e0433a50cbbce0fb034442d0201e19ff0abfbe
DIST rar2fs-1.27.2.tar.gz 259516 BLAKE2B ffa34fa5e38e22c0055c6a98442ad29a1ee62e215ff5e8fcc88a254a7de2d6c2842608adfeb22edece748dbc7173bba0574132cf8a9e735c5b84c53b0eb1b163 SHA512 7316198e1812cb88822e14c115d9dc0d98addeae3c6587888210197139046fb936ad3f1d599c45714c3d127535cf819311d314301249be78b91d66ebfc0fa453
diff --git a/sys-fs/rar2fs/rar2fs-1.27.1.ebuild b/sys-fs/rar2fs/rar2fs-1.27.1.ebuild
deleted file mode 100644
index 6bf7bd3f3ad1..000000000000
--- a/sys-fs/rar2fs/rar2fs-1.27.1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="A FUSE based filesystem that can mount one or multiple RAR archive(s)"
-HOMEPAGE="https://hasse69.github.io/rar2fs/ https://github.com/hasse69/rar2fs"
-SRC_URI="https://github.com/hasse69/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-
-RDEPEND=">=app-arch/unrar-5:=
- sys-fs/fuse:0"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- export USER_CFLAGS="${CFLAGS}"
-
- econf \
- --with-unrar=/usr/include/libunrar \
- --disable-static-unrar \
- $(use_enable debug)
-}
diff --git a/sys-fs/rar2fs/rar2fs-1.27.2.ebuild b/sys-fs/rar2fs/rar2fs-1.27.2.ebuild
deleted file mode 100644
index d072f4d0c56c..000000000000
--- a/sys-fs/rar2fs/rar2fs-1.27.2.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="A FUSE based filesystem that can mount one or multiple RAR archive(s)"
-HOMEPAGE="https://hasse69.github.io/rar2fs/ https://github.com/hasse69/rar2fs"
-SRC_URI="https://github.com/hasse69/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-
-RDEPEND=">=app-arch/unrar-5
- sys-fs/fuse:0"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- export USER_CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS} -I/usr/include/libunrar"
-
- # use static lib to avoid ABI breaks when upstream doesn't follow semantic versioning
- econf \
- --with-unrar="/usr/$(get_libdir)" \
- --enable-static-unrar \
- $(use_enable debug)
-}