summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-09 17:10:23 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-09 17:14:15 +0100
commit5fa9f8aaffeef3b0fb2cb75bde0b49dd9f355d63 (patch)
tree8ec06da99a8257a09c816db3f3c1f04952ea80e6 /sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
parentnet-misc/asterisk: 13.19.2 for CVE-2018-7284 & CVE-2018-7286 (diff)
downloadgentoo-5fa9f8aaffeef3b0fb2cb75bde0b49dd9f355d63.tar.gz
gentoo-5fa9f8aaffeef3b0fb2cb75bde0b49dd9f355d63.tar.bz2
gentoo-5fa9f8aaffeef3b0fb2cb75bde0b49dd9f355d63.zip
sys-libs/llvm-libunwind: Correct test dependencies
Diffstat (limited to 'sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
index c16358fe4c62..387b8c31086c 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
@@ -23,10 +23,13 @@ RESTRICT="!test? ( test )"
RDEPEND="!sys-libs/libunwind"
# llvm-6 for new lit options
+# tests need libcxx with implicit -lunwind and libcxxabi
+# (but libcxx does not need to be built against it)
DEPEND="
>=sys-devel/llvm-6
test? (
- sys-libs/libcxx[${MULTILIB_USEDEP}]
+ sys-libs/libcxx[libunwind,${MULTILIB_USEDEP}]
+ sys-libs/libcxxabi
$(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]') )"
# least intrusive of all