summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gmail.com>2015-08-13 11:35:02 +0300
committerAndrew Savchenko <bircoph@gmail.com>2015-08-13 11:43:51 +0300
commitc89cc97d9a8f30e5762f1f32cf9c16a859de8c0d (patch)
treeb1603a000692e761a27ca0fa424651b103aad947 /sys-power/suspend/suspend-1.0_p20150810.ebuild
parentdev-dotnet/gnome-sharp 2.24.2-r1 (monolithic) (diff)
downloadgentoo-c89cc97d9a8f30e5762f1f32cf9c16a859de8c0d.tar.gz
gentoo-c89cc97d9a8f30e5762f1f32cf9c16a859de8c0d.tar.bz2
gentoo-c89cc97d9a8f30e5762f1f32cf9c16a859de8c0d.zip
sys-power/suspend: fix bug 556954
Fix build with fbsplash support in case when mediag-gfx/splashutils are compiled with media-libs/freetype support which is compiled with app-arch/bzip2 support. This issue is a combination of multiple bugs: 1. media-gfx/splashutils provides incomplete list of libraries for static linking. See bug 408283. 2. media-gfx/splashutils contains bogus entry in the list of static libraries. See bug 557126. 3. suspend asks splashutils for a list of dynamic libs instead of static. This is fixed in this commit. Signed-off-by: Andrew Savchenko <bircoph@gmail.com>
Diffstat (limited to 'sys-power/suspend/suspend-1.0_p20150810.ebuild')
-rw-r--r--sys-power/suspend/suspend-1.0_p20150810.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sys-power/suspend/suspend-1.0_p20150810.ebuild b/sys-power/suspend/suspend-1.0_p20150810.ebuild
new file mode 100644
index 000000000000..14f03d9383fb
--- /dev/null
+++ b/sys-power/suspend/suspend-1.0_p20150810.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+BASE_PV="1.0_p20120915"
+
+DESCRIPTION="Userspace Software Suspend and S2Ram"
+HOMEPAGE="http://suspend.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~bircoph/distfiles/${PN}-${BASE_PV}.tar.xz
+ http://dev.gentoo.org/~bircoph/patches/${P}.patch.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crypt fbsplash +lzo threads"
+
+RDEPEND="
+ dev-libs/libx86
+ crypt? (
+ >=dev-libs/libgcrypt-1.6.3:0[static-libs]
+ dev-libs/libgpg-error[static-libs] )
+ fbsplash? ( >=media-gfx/splashutils-1.5.4.4-r6 )
+ lzo? ( >=dev-libs/lzo-2[static-libs] ) "
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5.10
+ >=sys-apps/pciutils-2.2.4
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${WORKDIR}/${P}.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ $(use_enable crypt encrypt) \
+ $(use_enable fbsplash) \
+ $(use_enable lzo compress) \
+ $(use_enable threads)
+}
+
+src_install() {
+ dodir etc
+ emake DESTDIR="${D}" install
+ rm "${D}/usr/share/doc/${PF}"/COPYING* || die
+}
+
+pkg_postinst() {
+ elog "In order to make this package work with genkernel see:"
+ elog "http://bugs.gentoo.org/show_bug.cgi?id=156445"
+}