summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-26 13:26:14 +0100
committerSam James <sam@gentoo.org>2022-09-26 13:26:14 +0100
commit2e82ad643d809c8ac1cb5b92e46c10344e3c6be5 (patch)
treef53d1df8e3c2214c02f77a1db1a8a9c2a378ff72 /sys-process
parentsys-process/psinfo: fix 'unsigned char' issue in RISC-V/ARM64 platform (diff)
downloadgentoo-2e82ad643d809c8ac1cb5b92e46c10344e3c6be5.tar.gz
gentoo-2e82ad643d809c8ac1cb5b92e46c10344e3c6be5.tar.bz2
gentoo-2e82ad643d809c8ac1cb5b92e46c10344e3c6be5.zip
sys-process/psinfo: revbump for unsigned char fix
it's only keyworded on amd64/x86, but it affects runtime and it'll avoid confusion if any say, arm users have been using it (or trying to). Closes: https://bugs.gentoo.org/872821 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/psinfo/psinfo-0.12-r1.ebuild1
-rw-r--r--sys-process/psinfo/psinfo-0.12-r2.ebuild24
2 files changed, 24 insertions, 1 deletions
diff --git a/sys-process/psinfo/psinfo-0.12-r1.ebuild b/sys-process/psinfo/psinfo-0.12-r1.ebuild
index fdf62188a826..033fcddb450b 100644
--- a/sys-process/psinfo/psinfo-0.12-r1.ebuild
+++ b/sys-process/psinfo/psinfo-0.12-r1.ebuild
@@ -15,7 +15,6 @@ LICENSE="GPL-2"
PATCHES=(
"${FILESDIR}/${P}-asneeded.patch"
- "${FILESDIR}/${P}-char.patch"
)
src_prepare() {
diff --git a/sys-process/psinfo/psinfo-0.12-r2.ebuild b/sys-process/psinfo/psinfo-0.12-r2.ebuild
new file mode 100644
index 000000000000..fdf62188a826
--- /dev/null
+++ b/sys-process/psinfo/psinfo-0.12-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Process information and statistics using the kernel /proc interface"
+HOMEPAGE="http://www.ward.nu/computer/psinfo/"
+SRC_URI="http://www.ward.nu/computer/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+
+PATCHES=(
+ "${FILESDIR}/${P}-asneeded.patch"
+ "${FILESDIR}/${P}-char.patch"
+)
+
+src_prepare() {
+ default
+ tc-export CC
+}