summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /virtual/opencl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'virtual/opencl')
-rw-r--r--virtual/opencl/metadata.xml5
-rw-r--r--virtual/opencl/opencl-0-r2.ebuild25
-rw-r--r--virtual/opencl/opencl-0-r3.ebuild24
-rw-r--r--virtual/opencl/opencl-0-r4.ebuild29
-rw-r--r--virtual/opencl/opencl-0.ebuild26
5 files changed, 109 insertions, 0 deletions
diff --git a/virtual/opencl/metadata.xml b/virtual/opencl/metadata.xml
new file mode 100644
index 000000000000..01c4c004e735
--- /dev/null
+++ b/virtual/opencl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>
diff --git a/virtual/opencl/opencl-0-r2.ebuild b/virtual/opencl/opencl-0-r2.ebuild
new file mode 100644
index 000000000000..4c243e0a3b11
--- /dev/null
+++ b/virtual/opencl/opencl-0-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="Virtual for OpenCL implementations"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="amd64 x86"
+CARDS=( fglrx nvidia )
+IUSE="${CARDS[@]/#/video_cards_}"
+
+DEPEND=""
+RDEPEND="app-eselect/eselect-opencl
+ || (
+ video_cards_fglrx? ( >=x11-drivers/ati-drivers-12.1-r1 )
+ video_cards_nvidia? ( >=x11-drivers/nvidia-drivers-290.10-r2 )
+ dev-util/intel-ocl-sdk
+ )"
+
+REQUIRED_USE="x86? ( || ( video_cards_fglrx video_cards_nvidia ) )"
diff --git a/virtual/opencl/opencl-0-r3.ebuild b/virtual/opencl/opencl-0-r3.ebuild
new file mode 100644
index 000000000000..8b265e610af8
--- /dev/null
+++ b/virtual/opencl/opencl-0-r3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Virtual for OpenCL implementations"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+CARDS=( fglrx nvidia )
+IUSE="${CARDS[@]/#/video_cards_}"
+
+DEPEND=""
+RDEPEND="app-eselect/eselect-opencl
+ || (
+ media-libs/mesa[opencl]
+ video_cards_fglrx? ( >=x11-drivers/ati-drivers-12.1-r1 )
+ video_cards_nvidia? ( >=x11-drivers/nvidia-drivers-290.10-r2 )
+ dev-util/intel-ocl-sdk
+ )"
diff --git a/virtual/opencl/opencl-0-r4.ebuild b/virtual/opencl/opencl-0-r4.ebuild
new file mode 100644
index 000000000000..2ebd296dabfb
--- /dev/null
+++ b/virtual/opencl/opencl-0-r4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for OpenCL implementations"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+CARDS=( fglrx nvidia )
+IUSE="${CARDS[@]/#/video_cards_}"
+
+DEPEND=""
+# intel-ocl-sdk is amd64-only
+RDEPEND="app-eselect/eselect-opencl
+ || (
+ >=media-libs/mesa-9.1.6[opencl,${MULTILIB_USEDEP}]
+ video_cards_fglrx? (
+ >=x11-drivers/ati-drivers-12.1-r1 )
+ video_cards_nvidia? (
+ >=x11-drivers/nvidia-drivers-290.10-r2 )
+ abi_x86_64? ( !abi_x86_32? ( dev-util/intel-ocl-sdk ) )
+ )"
diff --git a/virtual/opencl/opencl-0.ebuild b/virtual/opencl/opencl-0.ebuild
new file mode 100644
index 000000000000..4fff3861bd62
--- /dev/null
+++ b/virtual/opencl/opencl-0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Until ATI's SDK is in the tree, nvidia is the only
+# viable provider #392179 #257626
+
+EAPI="4"
+
+DESCRIPTION="Virtual for OpenCL implementations"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="amd64 x86"
+#CARDS=( fglrx nvidia )
+CARDS=( nvidia )
+IUSE="${CARDS[@]/#/video_cards_}"
+
+REQUIRED_USE="|| ( ${IUSE} )"
+
+# video_cards_fglrx? ( x11-drivers/ati-drivers[opencl] )
+RDEPEND="|| (
+ video_cards_nvidia? ( x11-drivers/nvidia-drivers >=dev-util/nvidia-cuda-toolkit-3.1 )
+ )"