summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-09-03 14:04:37 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-09-03 14:11:51 +0200
commitc86b235dd20616fa9f5f70ca763c237d68c5eb76 (patch)
tree7a95074b6d4fbd43409773d54f53ee7cbd85a14a /www-apache/mod_wsgi/mod_wsgi-4.7.1.ebuild
parentnet-p2p/amule: Fix compilation with libupnp 1.14. (diff)
downloadgentoo-c86b235dd20616fa9f5f70ca763c237d68c5eb76.tar.gz
gentoo-c86b235dd20616fa9f5f70ca763c237d68c5eb76.tar.bz2
gentoo-c86b235dd20616fa9f5f70ca763c237d68c5eb76.zip
www-apache/mod_wsgi: Bump to version 4.7.1
- Bumped to EAPI-6 - Added python3_8 support - Explicitly call python-single-r1_pkg_setup - Worked around apache-modules.eclass annoyances - Forced bash as config shell because configure script contains bashisms Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'www-apache/mod_wsgi/mod_wsgi-4.7.1.ebuild')
-rw-r--r--www-apache/mod_wsgi/mod_wsgi-4.7.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/www-apache/mod_wsgi/mod_wsgi-4.7.1.ebuild b/www-apache/mod_wsgi/mod_wsgi-4.7.1.ebuild
new file mode 100644
index 000000000000..9415402eae83
--- /dev/null
+++ b/www-apache/mod_wsgi/mod_wsgi-4.7.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit apache-module eutils python-single-r1
+
+DESCRIPTION="An Apache2 module for running Python WSGI applications"
+HOMEPAGE="https://github.com/GrahamDumpleton/mod_wsgi"
+SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}"
+
+APACHE2_MOD_CONF="70_${PN}"
+APACHE2_MOD_DEFINE="WSGI"
+APACHE2_MOD_FILE="${S}/src/server/.libs/${PN}.so"
+
+DOCFILES="README.rst"
+
+need_apache2
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+
+ # Calling depend.apache_pkg_setup fails because we do not have
+ # "apache2" in IUSE but the function expects this in order to call
+ # _init_apache2_late which sets the APACHE_MODULESDIR variable.
+ _init_apache2
+ _init_apache2_late
+}
+
+src_configure() {
+ # configure.ac contains bashisms
+ # (https://github.com/GrahamDumpleton/mod_wsgi/issues/567)
+ CONFIG_SHELL="/bin/bash" \
+ econf --with-apxs="${APXS}" --with-python="${PYTHON}"
+}
+
+src_compile() {
+ default
+}