summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-02-07 10:54:06 -0500
committerBrian Evans <grknight@gentoo.org>2019-02-07 10:54:06 -0500
commit0f9f86e6f09c09be343aaa2f1c64837f3dd7ce23 (patch)
treeaf8ae09d2656890cb9adda7cf4c01c2216772cc0 /www-apache
parentmedia-plugins/kodi-pvr-vuplus: Cleanup old versions (diff)
downloadgentoo-0f9f86e6f09c09be343aaa2f1c64837f3dd7ce23.tar.gz
gentoo-0f9f86e6f09c09be343aaa2f1c64837f3dd7ce23.tar.bz2
gentoo-0f9f86e6f09c09be343aaa2f1c64837f3dd7ce23.zip
www-apache/mod_musicindex: Revbump for dependency and EAPI change
Closes: https://bugs.gentoo.org/666076 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_musicindex/mod_musicindex-1.4.1-r1.ebuild (renamed from www-apache/mod_musicindex/mod_musicindex-1.4.1.ebuild)16
1 files changed, 10 insertions, 6 deletions
diff --git a/www-apache/mod_musicindex/mod_musicindex-1.4.1.ebuild b/www-apache/mod_musicindex/mod_musicindex-1.4.1-r1.ebuild
index d87b3ed75c33..a033588e3669 100644
--- a/www-apache/mod_musicindex/mod_musicindex-1.4.1.ebuild
+++ b/www-apache/mod_musicindex/mod_musicindex-1.4.1-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit apache-module
@@ -22,16 +22,20 @@ DEPEND="mp3? ( media-libs/libmad media-libs/libid3tag )
flac? ( media-libs/flac )
vorbis? ( media-libs/libvorbis )
archive? ( app-arch/libarchive )
- mysql? ( virtual/mysql )"
+ mysql? ( dev-db/mysql-connector-c:0= )"
RDEPEND="${DEPEND}
sys-devel/libtool"
APACHE2_MOD_CONF="50_${PN}"
APACHE2_MOD_DEFINE="MUSICINDEX"
-DOCFILES="AUTHORS BUGS ChangeLog README UPGRADING"
+DOCS=( AUTHORS BUGS ChangeLog README UPGRADING )
need_apache2
+pkg_setup() {
+ _init_apache2_late
+}
+
src_configure() {
econf \
$(use_enable mp3) \
@@ -44,11 +48,11 @@ src_configure() {
}
src_compile() {
- emake || die "emake failed"
+ default
}
src_install() {
- emake DESTDIR="${D}" install || die "emake failed"
+ default
apache-module_src_install
# install W3C images