summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-12-31 04:10:39 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-12-31 04:11:09 -0800
commit4456c756e6e3f911e06a4ff26dd890d8370e1d95 (patch)
treec7603df23a6bbfae90915af74a9c34528dfacabd /www-plugins
parentwww-plugins/passff-host: drop 1.2.2 (diff)
downloadgentoo-4456c756e6e3f911e06a4ff26dd890d8370e1d95.tar.gz
gentoo-4456c756e6e3f911e06a4ff26dd890d8370e1d95.tar.bz2
gentoo-4456c756e6e3f911e06a4ff26dd890d8370e1d95.zip
www-plugins/passff-host: add pinentry to rdepend
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/passff-host/passff-host-1.2.3-r1.ebuild (renamed from www-plugins/passff-host/passff-host-1.2.3.ebuild)11
1 files changed, 10 insertions, 1 deletions
diff --git a/www-plugins/passff-host/passff-host-1.2.3.ebuild b/www-plugins/passff-host/passff-host-1.2.3-r1.ebuild
index 3c481e7e23ec..0f40d6776d69 100644
--- a/www-plugins/passff-host/passff-host-1.2.3.ebuild
+++ b/www-plugins/passff-host/passff-host-1.2.3-r1.ebuild
@@ -24,7 +24,10 @@ REQUIRED_USE="
|| ( chrome chromium firefox vivaldi )
"
-RDEPEND="${PYTHON_DEPS}"
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-crypt/pinentry
+"
S="${WORKDIR}"
@@ -57,3 +60,9 @@ src_install() {
newexe "${P}.py" passff.py
done
}
+
+pkg_postinst() {
+ elog "Make sure to use graphical version of pinentry for ${PN} to work properly"
+ elog "Run 'eselect pinentry list'"
+ elog "And select 'pinentry-qt5' or 'pinentry-gnome'. efl might work too."
+}