summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/passff-host/passff-host-1.2.3-r1.ebuild (renamed from www-plugins/passff-host/passff-host-1.2.3.ebuild)11
1 files changed, 10 insertions, 1 deletions
diff --git a/www-plugins/passff-host/passff-host-1.2.3.ebuild b/www-plugins/passff-host/passff-host-1.2.3-r1.ebuild
index 3c481e7e23ec..0f40d6776d69 100644
--- a/www-plugins/passff-host/passff-host-1.2.3.ebuild
+++ b/www-plugins/passff-host/passff-host-1.2.3-r1.ebuild
@@ -24,7 +24,10 @@ REQUIRED_USE="
|| ( chrome chromium firefox vivaldi )
"
-RDEPEND="${PYTHON_DEPS}"
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-crypt/pinentry
+"
S="${WORKDIR}"
@@ -57,3 +60,9 @@ src_install() {
newexe "${P}.py" passff.py
done
}
+
+pkg_postinst() {
+ elog "Make sure to use graphical version of pinentry for ${PN} to work properly"
+ elog "Run 'eselect pinentry list'"
+ elog "And select 'pinentry-qt5' or 'pinentry-gnome'. efl might work too."
+}