summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-05-02 01:55:05 +0200
committerMatt Turner <mattst88@gentoo.org>2021-05-02 11:24:43 -0400
commit4acac25b3d18896ac3a7d291494b12d481aa6fba (patch)
tree8e0b2c2744e4433c6513f8781b8c45d7128c4cc7 /x11-apps
parentmedia-fonts/font-util: Clean up XORG_CONFIGURE_OPTIONS (diff)
downloadgentoo-4acac25b3d18896ac3a7d291494b12d481aa6fba.tar.gz
gentoo-4acac25b3d18896ac3a7d291494b12d481aa6fba.tar.bz2
gentoo-4acac25b3d18896ac3a7d291494b12d481aa6fba.zip
x11-apps/xauth: Define XORG_CONFIGURE_OPTIONS in src_configure
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xauth/xauth-1.1.ebuild5
-rw-r--r--x11-apps/xauth/xauth-9999.ebuild7
2 files changed, 7 insertions, 5 deletions
diff --git a/x11-apps/xauth/xauth-1.1.ebuild b/x11-apps/xauth/xauth-1.1.ebuild
index d81c5122af45..fe2bc9e5bdcf 100644
--- a/x11-apps/xauth/xauth-1.1.ebuild
+++ b/x11-apps/xauth/xauth-1.1.ebuild
@@ -22,8 +22,9 @@ RDEPEND="x11-libs/libX11
DEPEND="${RDEPEND}
x11-base/xorg-proto"
-pkg_setup() {
- XORG_CONFIGURE_OPTIONS=(
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
$(use_enable ipv6)
)
+ xorg-3_src_configure
}
diff --git a/x11-apps/xauth/xauth-9999.ebuild b/x11-apps/xauth/xauth-9999.ebuild
index f46da39bc300..50da5eb529dd 100644
--- a/x11-apps/xauth/xauth-9999.ebuild
+++ b/x11-apps/xauth/xauth-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,8 +22,9 @@ RDEPEND="x11-libs/libX11
DEPEND="${RDEPEND}
x11-base/xorg-proto"
-pkg_setup() {
- XORG_CONFIGURE_OPTIONS=(
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
$(use_enable ipv6)
)
+ xorg-3_src_configure
}