summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xauth/xauth-1.1.ebuild5
-rw-r--r--x11-apps/xauth/xauth-9999.ebuild7
2 files changed, 7 insertions, 5 deletions
diff --git a/x11-apps/xauth/xauth-1.1.ebuild b/x11-apps/xauth/xauth-1.1.ebuild
index d81c5122af45..fe2bc9e5bdcf 100644
--- a/x11-apps/xauth/xauth-1.1.ebuild
+++ b/x11-apps/xauth/xauth-1.1.ebuild
@@ -22,8 +22,9 @@ RDEPEND="x11-libs/libX11
DEPEND="${RDEPEND}
x11-base/xorg-proto"
-pkg_setup() {
- XORG_CONFIGURE_OPTIONS=(
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
$(use_enable ipv6)
)
+ xorg-3_src_configure
}
diff --git a/x11-apps/xauth/xauth-9999.ebuild b/x11-apps/xauth/xauth-9999.ebuild
index f46da39bc300..50da5eb529dd 100644
--- a/x11-apps/xauth/xauth-9999.ebuild
+++ b/x11-apps/xauth/xauth-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,8 +22,9 @@ RDEPEND="x11-libs/libX11
DEPEND="${RDEPEND}
x11-base/xorg-proto"
-pkg_setup() {
- XORG_CONFIGURE_OPTIONS=(
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
$(use_enable ipv6)
)
+ xorg-3_src_configure
}