summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-11-27 16:02:24 +0100
committerJeroen Roovers <jer@gentoo.org>2019-11-27 16:07:01 +0100
commit232dfcd76959f6996ae76528303916967527530a (patch)
tree0bf02bde28ed8782a7dbb1ac81527cec4bb6b5ce /x11-drivers
parenteclass/nvidia-driver.eclass: Add nvidia-driver_check(), various tweaks (diff)
downloadgentoo-232dfcd76959f6996ae76528303916967527530a.tar.gz
gentoo-232dfcd76959f6996ae76528303916967527530a.tar.bz2
gentoo-232dfcd76959f6996ae76528303916967527530a.zip
x11-drivers/nvidia-drivers: EAPI=7, use nvidia-driver_check()
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-340.107-r1.ebuild52
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-390.129.ebuild49
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-390.132.ebuild49
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-430.64.ebuild46
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-435.21.ebuild46
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-440.31.ebuild46
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-440.36.ebuild46
7 files changed, 55 insertions, 279 deletions
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-340.107-r1.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-340.107-r1.ebuild
index 5f370d0daef9..b34dd6830339 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-340.107-r1.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-340.107-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils flag-o-matic linux-info linux-mod multilib-minimal nvidia-driver \
- portability toolchain-funcs unpacker user udev
+EAPI=7
+inherit desktop flag-o-matic linux-info linux-mod multilib-minimal \
+ nvidia-driver portability toolchain-funcs unpacker user udev
NV_URI="https://us.download.nvidia.com/XFree86/"
X86_NV_PACKAGE="NVIDIA-Linux-x86-${PV}"
@@ -66,54 +66,20 @@ RDEPEND="
)
)
"
-
REQUIRED_USE="tools? ( X )"
-
QA_PREBUILT="opt/* usr/lib*"
-
S=${WORKDIR}/
-
-nvidia_drivers_versions_check() {
- if use amd64 && has_multilib_profile && \
- [ "${DEFAULT_ABI}" != "amd64" ]; then
- eerror "This ebuild doesn't currently support changing your default ABI"
- die "Unexpected \${DEFAULT_ABI} = ${DEFAULT_ABI}"
- fi
-
- if use kernel_linux && kernel_is ge 4 18; then
- ewarn "Gentoo supports kernels which are supported by NVIDIA"
- ewarn "which are limited to the following kernels:"
- ewarn "<sys-kernel/gentoo-sources-4.18"
- ewarn "<sys-kernel/vanilla-sources-4.18"
- ewarn ""
- ewarn "You are free to utilize eapply_user to provide whatever"
- ewarn "support you feel is appropriate, but will not receive"
- ewarn "support as a result of those changes."
- ewarn ""
- ewarn "Do not file a bug report about this."
- ewarn ""
- fi
-
- # Since Nvidia ships many different series of drivers, we need to give the user
- # some kind of guidance as to what version they should install. This tries
- # to point the user in the right direction but can't be perfect. check
- # nvidia-driver.eclass
- nvidia-driver-check-warning
-
- # Kernel features/options to check for
- CONFIG_CHECK="!DEBUG_MUTEXES ~!LOCKDEP ~MTRR ~SYSVIPC ~ZONE_DMA"
- use x86 && CONFIG_CHECK+=" ~HIGHMEM"
-
- # Now do the above checks
- use kernel_linux && check_extra_config
-}
+NV_KV_MAX_PLUS="4.18"
+CONFIG_CHECK="!DEBUG_MUTEXES ~!LOCKDEP ~MTRR ~SYSVIPC ~ZONE_DMA"
pkg_pretend() {
- nvidia_drivers_versions_check
+ use x86 && CONFIG_CHECK+=" ~HIGHMEM"
+ nvidia-driver_check
}
pkg_setup() {
- nvidia_drivers_versions_check
+ use x86 && CONFIG_CHECK+=" ~HIGHMEM"
+ nvidia-driver_check
# try to turn off distcc and ccache for people that have a problem with it
export DISTCC_DISABLE=1
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-390.129.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-390.129.ebuild
index 705a1973f016..152ff221b9a3 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-390.129.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-390.129.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils flag-o-matic linux-info linux-mod multilib-minimal nvidia-driver \
- portability toolchain-funcs unpacker user udev
+EAPI=7
+inherit desktop flag-o-matic linux-info linux-mod multilib-minimal \
+ nvidia-driver portability toolchain-funcs unpacker user udev
DESCRIPTION="NVIDIA Accelerated Graphics Driver"
HOMEPAGE="https://www.nvidia.com/"
@@ -82,48 +82,17 @@ RDEPEND="
"
QA_PREBUILT="opt/* usr/lib*"
S=${WORKDIR}/
-
-nvidia_drivers_versions_check() {
- if use amd64 && has_multilib_profile && \
- [ "${DEFAULT_ABI}" != "amd64" ]; then
- eerror "This ebuild doesn't currently support changing your default ABI"
- die "Unexpected \${DEFAULT_ABI} = ${DEFAULT_ABI}"
- fi
-
- if use kernel_linux && kernel_is ge 5 4; then
- ewarn "Gentoo supports kernels which are supported by NVIDIA"
- ewarn "which are limited to the following kernels:"
- ewarn "<sys-kernel/gentoo-sources-5.4"
- ewarn "<sys-kernel/vanilla-sources-5.4"
- ewarn ""
- ewarn "You are free to utilize epatch_user to provide whatever"
- ewarn "support you feel is appropriate, but will not receive"
- ewarn "support as a result of those changes."
- ewarn ""
- ewarn "Do not file a bug report about this."
- ewarn ""
- fi
-
- # Since Nvidia ships many different series of drivers, we need to give the user
- # some kind of guidance as to what version they should install. This tries
- # to point the user in the right direction but can't be perfect. check
- # nvidia-driver.eclass
- nvidia-driver-check-warning
-
- # Kernel features/options to check for
- CONFIG_CHECK="!DEBUG_MUTEXES ~!LOCKDEP ~MTRR ~SYSVIPC ~ZONE_DMA"
- use x86 && CONFIG_CHECK+=" ~HIGHMEM"
-
- # Now do the above checks
- use kernel_linux && check_extra_config
-}
+NV_KV_MAX_PLUS="5.4"
+CONFIG_CHECK="!DEBUG_MUTEXES ~!LOCKDEP ~MTRR ~SYSVIPC ~ZONE_DMA"
pkg_pretend() {
- nvidia_drivers_versions_check
+ use x86 && CONFIG_CHECK+=" ~HIGHMEM"
+ nvidia-driver_check
}
pkg_setup() {
- nvidia_drivers_versions_check
+ use x86 && CONFIG_CHECK+=" ~HIGHMEM"
+ nvidia-driver_check
# try to turn off distcc and ccache for people that have a problem with it
export DISTCC_DISABLE=1
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-390.132.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-390.132.ebuild
index 368ed5f2bcda..4860d956b4b4 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-390.132.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-390.132.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils flag-o-matic linux-info linux-mod multilib-minimal nvidia-driver \
- portability toolchain-funcs unpacker user udev
+EAPI=7
+inherit desktop flag-o-matic linux-info linux-mod multilib-minimal \
+ nvidia-driver portability toolchain-funcs unpacker user udev
DESCRIPTION="NVIDIA Accelerated Graphics Driver"
HOMEPAGE="https://www.nvidia.com/"
@@ -82,48 +82,17 @@ RDEPEND="
"
QA_PREBUILT="opt/* usr/lib*"
S=${WORKDIR}/
-
-nvidia_drivers_versions_check() {
- if use amd64 && has_multilib_profile && \
- [ "${DEFAULT_ABI}" != "amd64" ]; then
- eerror "This ebuild doesn't currently support changing your default ABI"
- die "Unexpected \${DEFAULT_ABI} = ${DEFAULT_ABI}"
- fi
-
- if use kernel_linux && kernel_is ge 5 4; then
- ewarn "Gentoo supports kernels which are supported by NVIDIA"
- ewarn "which are limited to the following kernels:"
- ewarn "<sys-kernel/gentoo-sources-5.4"
- ewarn "<sys-kernel/vanilla-sources-5.4"
- ewarn ""
- ewarn "You are free to utilize epatch_user to provide whatever"
- ewarn "support you feel is appropriate, but will not receive"
- ewarn "support as a result of those changes."
- ewarn ""
- ewarn "Do not file a bug report about this."
- ewarn ""
- fi
-
- # Since Nvidia ships many different series of drivers, we need to give the user
- # some kind of guidance as to what version they should install. This tries
- # to point the user in the right direction but can't be perfect. check
- # nvidia-driver.eclass
- nvidia-driver-check-warning
-
- # Kernel features/options to check for
- CONFIG_CHECK="!DEBUG_MUTEXES ~!LOCKDEP ~MTRR ~SYSVIPC ~ZONE_DMA"
- use x86 && CONFIG_CHECK+=" ~HIGHMEM"
-
- # Now do the above checks
- use kernel_linux && check_extra_config
-}
+NV_KV_MAX_PLUS="5.4"
+CONFIG_CHECK="!DEBUG_MUTEXES ~!LOCKDEP ~MTRR ~SYSVIPC ~ZONE_DMA"
pkg_pretend() {
- nvidia_drivers_versions_check
+ use x86 && CONFIG_CHECK+=" ~HIGHMEM"
+ nvidia-driver_check
}
pkg_setup() {
- nvidia_drivers_versions_check
+ use x86 && CONFIG_CHECK+=" ~HIGHMEM"
+ nvidia-driver_check
# try to turn off distcc and ccache for people that have a problem with it
export DISTCC_DISABLE=1
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-430.64.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-430.64.ebuild
index 4c25381ffa11..527d41f645f6 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-430.64.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-430.64.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils flag-o-matic linux-info linux-mod multilib-minimal nvidia-driver \
- portability toolchain-funcs unpacker user udev
+EAPI=7
+inherit desktop flag-o-matic linux-info linux-mod multilib-minimal \
+ nvidia-driver portability toolchain-funcs unpacker user udev
DESCRIPTION="NVIDIA Accelerated Graphics Driver"
HOMEPAGE="https://www.nvidia.com/"
@@ -77,47 +77,15 @@ RDEPEND="
"
QA_PREBUILT="opt/* usr/lib*"
S=${WORKDIR}/
-
-nvidia_drivers_versions_check() {
- if use amd64 && has_multilib_profile && \
- [ "${DEFAULT_ABI}" != "amd64" ]; then
- eerror "This ebuild doesn't currently support changing your default ABI"
- die "Unexpected \${DEFAULT_ABI} = ${DEFAULT_ABI}"
- fi
-
- if use kernel_linux && kernel_is ge 5 4; then
- ewarn "Gentoo supports kernels which are supported by NVIDIA"
- ewarn "which are limited to the following kernels:"
- ewarn "<sys-kernel/gentoo-sources-5.4"
- ewarn "<sys-kernel/vanilla-sources-5.4"
- ewarn ""
- ewarn "You are free to utilize epatch_user to provide whatever"
- ewarn "support you feel is appropriate, but will not receive"
- ewarn "support as a result of those changes."
- ewarn ""
- ewarn "Do not file a bug report about this."
- ewarn ""
- fi
-
- # Since Nvidia ships many different series of drivers, we need to give the user
- # some kind of guidance as to what version they should install. This tries
- # to point the user in the right direction but can't be perfect. check
- # nvidia-driver.eclass
- nvidia-driver-check-warning
-
- # Kernel features/options to check for
- CONFIG_CHECK="!DEBUG_MUTEXES !I2C_NVIDIA_GPU ~!LOCKDEP ~MTRR ~SYSVIPC ~ZONE_DMA"
-
- # Now do the above checks
- use kernel_linux && check_extra_config
-}
+NV_KV_MAX_PLUS="5.4"
+CONFIG_CHECK="!DEBUG_MUTEXES !I2C_NVIDIA_GPU ~!LOCKDEP ~MTRR ~SYSVIPC ~ZONE_DMA"
pkg_pretend() {
- nvidia_drivers_versions_check
+ nvidia-driver_check
}
pkg_setup() {
- nvidia_drivers_versions_check
+ nvidia-driver_check
# try to turn off distcc and ccache for people that have a problem with it
export DISTCC_DISABLE=1
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-435.21.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-435.21.ebuild
index ba476b4116db..42b292bb521b 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-435.21.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-435.21.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils flag-o-matic linux-info linux-mod multilib-minimal nvidia-driver \
- portability toolchain-funcs unpacker user udev
+EAPI=7
+inherit desktop flag-o-matic linux-info linux-mod multilib-minimal \
+ nvidia-driver portability toolchain-funcs unpacker user udev
DESCRIPTION="NVIDIA Accelerated Graphics Driver"
HOMEPAGE="https://www.nvidia.com/"
@@ -81,47 +81,15 @@ RDEPEND="
"
QA_PREBUILT="opt/* usr/lib*"
S=${WORKDIR}/
-
-nvidia_drivers_versions_check() {
- if use amd64 && has_multilib_profile && \
- [ "${DEFAULT_ABI}" != "amd64" ]; then
- eerror "This ebuild doesn't currently support changing your default ABI"
- die "Unexpected \${DEFAULT_ABI} = ${DEFAULT_ABI}"
- fi
-
- if use kernel_linux && kernel_is ge 5 4; then
- ewarn "Gentoo supports kernels which are supported by NVIDIA"
- ewarn "which are limited to the following kernels:"
- ewarn "<sys-kernel/gentoo-sources-5.4"
- ewarn "<sys-kernel/vanilla-sources-5.4"
- ewarn ""
- ewarn "You are free to utilize epatch_user to provide whatever"
- ewarn "support you feel is appropriate, but will not receive"
- ewarn "support as a result of those changes."
- ewarn ""
- ewarn "Do not file a bug report about this."
- ewarn ""
- fi
-
- # Since Nvidia ships many different series of drivers, we need to give the user
- # some kind of guidance as to what version they should install. This tries
- # to point the user in the right direction but can't be perfect. check
- # nvidia-driver.eclass
- nvidia-driver-check-warning
-
- # Kernel features/options to check for
- CONFIG_CHECK="!DEBUG_MUTEXES !I2C_NVIDIA_GPU ~!LOCKDEP ~MTRR ~SYSVIPC ~ZONE_DMA"
-
- # Now do the above checks
- use kernel_linux && check_extra_config
-}
+NV_KV_MAX_PLUS="5.4"
+CONFIG_CHECK="!DEBUG_MUTEXES !I2C_NVIDIA_GPU ~!LOCKDEP ~MTRR ~SYSVIPC ~ZONE_DMA"
pkg_pretend() {
- nvidia_drivers_versions_check
+ nvidia-driver_check
}
pkg_setup() {
- nvidia_drivers_versions_check
+ nvidia-driver_check
# try to turn off distcc and ccache for people that have a problem with it
export DISTCC_DISABLE=1
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-440.31.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-440.31.ebuild
index be2de040f761..4acf4397da75 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-440.31.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-440.31.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils flag-o-matic linux-info linux-mod multilib-minimal nvidia-driver \
- portability toolchain-funcs unpacker user udev
+EAPI=7
+inherit desktop flag-o-matic linux-info linux-mod multilib-minimal \
+ nvidia-driver portability toolchain-funcs unpacker user udev
DESCRIPTION="NVIDIA Accelerated Graphics Driver"
HOMEPAGE="https://www.nvidia.com/"
@@ -84,47 +84,15 @@ S=${WORKDIR}/
PATCHES=(
"${FILESDIR}"/${PN}-440.26-locale.patch
)
-
-nvidia_drivers_versions_check() {
- if use amd64 && has_multilib_profile && \
- [ "${DEFAULT_ABI}" != "amd64" ]; then
- eerror "This ebuild doesn't currently support changing your default ABI"
- die "Unexpected \${DEFAULT_ABI} = ${DEFAULT_ABI}"
- fi
-
- if use kernel_linux && kernel_is ge 5 4; then
- ewarn "Gentoo supports kernels which are supported by NVIDIA"
- ewarn "which are limited to the following kernels:"
- ewarn "<sys-kernel/gentoo-sources-5.4"
- ewarn "<sys-kernel/vanilla-sources-5.4"
- ewarn ""
- ewarn "You are free to utilize epatch_user to provide whatever"
- ewarn "support you feel is appropriate, but will not receive"
- ewarn "support as a result of those changes."
- ewarn ""
- ewarn "Do not file a bug report about this."
- ewarn ""
- fi
-
- # Since Nvidia ships many different series of drivers, we need to give the user
- # some kind of guidance as to what version they should install. This tries
- # to point the user in the right direction but can't be perfect. check
- # nvidia-driver.eclass
- nvidia-driver-check-warning
-
- # Kernel features/options to check for
- CONFIG_CHECK="!DEBUG_MUTEXES !I2C_NVIDIA_GPU ~!LOCKDEP ~MTRR ~SYSVIPC ~ZONE_DMA"
-
- # Now do the above checks
- use kernel_linux && check_extra_config
-}
+NV_KV_MAX_PLUS="5.4"
+CONFIG_CHECK="!DEBUG_MUTEXES !I2C_NVIDIA_GPU ~!LOCKDEP ~MTRR ~SYSVIPC ~ZONE_DMA"
pkg_pretend() {
- nvidia_drivers_versions_check
+ nvidia-driver_check
}
pkg_setup() {
- nvidia_drivers_versions_check
+ nvidia-driver_check
# try to turn off distcc and ccache for people that have a problem with it
export DISTCC_DISABLE=1
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-440.36.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-440.36.ebuild
index f1723d4e80de..388adda4e50b 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-440.36.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-440.36.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils flag-o-matic linux-info linux-mod multilib-minimal nvidia-driver \
- portability toolchain-funcs unpacker user udev
+EAPI=7
+inherit desktop flag-o-matic linux-info linux-mod multilib-minimal \
+ nvidia-driver portability toolchain-funcs unpacker user udev
DESCRIPTION="NVIDIA Accelerated Graphics Driver"
HOMEPAGE="https://www.nvidia.com/"
@@ -84,47 +84,15 @@ S=${WORKDIR}/
PATCHES=(
"${FILESDIR}"/${PN}-440.26-locale.patch
)
-
-nvidia_drivers_versions_check() {
- if use amd64 && has_multilib_profile && \
- [ "${DEFAULT_ABI}" != "amd64" ]; then
- eerror "This ebuild doesn't currently support changing your default ABI"
- die "Unexpected \${DEFAULT_ABI} = ${DEFAULT_ABI}"
- fi
-
- if use kernel_linux && kernel_is ge 5 4; then
- ewarn "Gentoo supports kernels which are supported by NVIDIA"
- ewarn "which are limited to the following kernels:"
- ewarn "<sys-kernel/gentoo-sources-5.4"
- ewarn "<sys-kernel/vanilla-sources-5.4"
- ewarn ""
- ewarn "You are free to utilize epatch_user to provide whatever"
- ewarn "support you feel is appropriate, but will not receive"
- ewarn "support as a result of those changes."
- ewarn ""
- ewarn "Do not file a bug report about this."
- ewarn ""
- fi
-
- # Since Nvidia ships many different series of drivers, we need to give the user
- # some kind of guidance as to what version they should install. This tries
- # to point the user in the right direction but can't be perfect. check
- # nvidia-driver.eclass
- nvidia-driver-check-warning
-
- # Kernel features/options to check for
- CONFIG_CHECK="!DEBUG_MUTEXES !I2C_NVIDIA_GPU ~!LOCKDEP ~MTRR ~SYSVIPC ~ZONE_DMA"
-
- # Now do the above checks
- use kernel_linux && check_extra_config
-}
+NV_KV_MAX_PLUS="5.4"
+CONFIG_CHECK="!DEBUG_MUTEXES !I2C_NVIDIA_GPU ~!LOCKDEP ~MTRR ~SYSVIPC ~ZONE_DMA"
pkg_pretend() {
- nvidia_drivers_versions_check
+ nvidia-driver_check
}
pkg_setup() {
- nvidia_drivers_versions_check
+ nvidia-driver_check
# try to turn off distcc and ccache for people that have a problem with it
export DISTCC_DISABLE=1