summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac.paragon@gmail.com>2021-03-21 10:40:01 +0200
committerSam James <sam@gentoo.org>2021-03-27 16:42:30 +0000
commitbfb49fa661909c57e5c9db87fe30413d7c8c5e1b (patch)
tree78967178e9baefa9e10652ab77d255eace295425 /x11-libs/libXaw3dXft/libXaw3dXft-1.6.2h.ebuild
parentmedia-gfx/xpaint: fix passing LDFLAGS (diff)
downloadgentoo-bfb49fa661909c57e5c9db87fe30413d7c8c5e1b.tar.gz
gentoo-bfb49fa661909c57e5c9db87fe30413d7c8c5e1b.tar.bz2
gentoo-bfb49fa661909c57e5c9db87fe30413d7c8c5e1b.zip
x11-libs/libXaw3dXft: update to version 1.6.2h
Dependency of media-gfx/xpaint-3.1.3 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Viorel Munteanu <ceamac.paragon@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-libs/libXaw3dXft/libXaw3dXft-1.6.2h.ebuild')
-rw-r--r--x11-libs/libXaw3dXft/libXaw3dXft-1.6.2h.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-libs/libXaw3dXft/libXaw3dXft-1.6.2h.ebuild b/x11-libs/libXaw3dXft/libXaw3dXft-1.6.2h.ebuild
new file mode 100644
index 000000000000..3c771bc204fd
--- /dev/null
+++ b/x11-libs/libXaw3dXft/libXaw3dXft-1.6.2h.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xorg-3
+
+DESCRIPTION="Xaw3dXft library"
+HOMEPAGE="https://sourceforge.net/projects/sf-xpaint"
+SRC_URI="mirror://sourceforge/sf-xpaint/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="unicode xpm"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft
+ x11-libs/libXmu
+ x11-libs/libXt
+ xpm? ( x11-libs/libXpm )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="
+ sys-devel/flex
+ virtual/yacc"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable unicode internationalization)
+ $(usex xpm "--enable-multiplane-bitmaps" "")
+ --enable-arrow-scrollbars
+ --enable-gray-stipples
+ )
+ xorg-3_src_configure
+}