summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-04-14 08:30:48 -0400
committerJoonas Niilola <juippis@gentoo.org>2021-04-15 09:38:56 +0300
commit28291a79c8c9d1892b55e11c001ffb929c3f22d0 (patch)
tree24a777263961dc917dcacd96727a6f83d2620d01 /x11-misc/xbatt
parentx11-misc/xautolock: fix build with -native-symlinks (diff)
downloadgentoo-28291a79c8c9d1892b55e11c001ffb929c3f22d0.tar.gz
gentoo-28291a79c8c9d1892b55e11c001ffb929c3f22d0.tar.bz2
gentoo-28291a79c8c9d1892b55e11c001ffb929c3f22d0.zip
x11-misc/xbatt: fix build with -native-symlinks
Closes: https://bugs.gentoo.org/726220 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-misc/xbatt')
-rw-r--r--x11-misc/xbatt/xbatt-1.3_rc1.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/x11-misc/xbatt/xbatt-1.3_rc1.ebuild b/x11-misc/xbatt/xbatt-1.3_rc1.ebuild
index 75a3899848d4..df26d01cbd2c 100644
--- a/x11-misc/xbatt/xbatt-1.3_rc1.ebuild
+++ b/x11-misc/xbatt/xbatt-1.3_rc1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -24,15 +24,19 @@ RDEPEND="
DEPEND="
${RDEPEND}
x11-base/xorg-proto
- x11-misc/imake
+ >=x11-misc/imake-1.0.8-r1
"
PATCHES=(
"${FILESDIR}"/${PN}-1.2.1-implicits.patch
)
S="${WORKDIR}"/${PN}-$(ver_cut 1-2)
+src_configure() {
+ CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
+ IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die
+}
+
src_compile() {
- xmkmf || die
emake \
CC="$(tc-getCC)" \
CDEBUGFLAGS="${CFLAGS}" \