summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-14 00:17:49 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-14 00:17:49 +0100
commit7c39295646f5a76627428894bf751fd668c79a0d (patch)
tree3132ab690ee7a957317d45cedfe0f3cfbb7bb538 /x11-misc/xsettingsd/xsettingsd-1.0.2.ebuild
parentkde-frameworks/extra-cmake-modules: KDEFetchTranslations test broken (diff)
downloadgentoo-7c39295646f5a76627428894bf751fd668c79a0d.tar.gz
gentoo-7c39295646f5a76627428894bf751fd668c79a0d.tar.bz2
gentoo-7c39295646f5a76627428894bf751fd668c79a0d.zip
x11-misc/xsettingsd: 1.0.2 version bump
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-misc/xsettingsd/xsettingsd-1.0.2.ebuild')
-rw-r--r--x11-misc/xsettingsd/xsettingsd-1.0.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-misc/xsettingsd/xsettingsd-1.0.2.ebuild b/x11-misc/xsettingsd/xsettingsd-1.0.2.ebuild
new file mode 100644
index 000000000000..127a824fb368
--- /dev/null
+++ b/x11-misc/xsettingsd/xsettingsd-1.0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Provides settings to X11 applications via the XSETTINGS specification"
+HOMEPAGE="https://github.com/derat/xsettingsd"
+SRC_URI="https://github.com/derat/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+BDEPEND=">=dev-util/cmake-3.15"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ $(cmake_use_find_package test GTest)
+ )
+ cmake_src_configure
+}