summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-08 08:53:57 +0000
committerSam James <sam@gentoo.org>2021-12-08 08:53:57 +0000
commit2aedc281f377e84ad18d1580444ee296ade1b3fe (patch)
treedf91f73c7c1c1eaf2ae42cecb8bd2ecf3788a415 /x11-misc
parentsci-libs/hdf: keyword ~riscv (diff)
downloadgentoo-2aedc281f377e84ad18d1580444ee296ade1b3fe.tar.gz
gentoo-2aedc281f377e84ad18d1580444ee296ade1b3fe.tar.bz2
gentoo-2aedc281f377e84ad18d1580444ee296ade1b3fe.zip
x11-misc/xbindkeys: use eautoreconf for guile patch
We touch m4 => we need to regenerate configure (we're not patching it directly). Closes: https://bugs.gentoo.org/828555 Bug: https://bugs.gentoo.org/828532 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xbindkeys/xbindkeys-1.8.7-r2.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/x11-misc/xbindkeys/xbindkeys-1.8.7-r2.ebuild b/x11-misc/xbindkeys/xbindkeys-1.8.7-r2.ebuild
index 7b821afa63e4..03a121ac68a1 100644
--- a/x11-misc/xbindkeys/xbindkeys-1.8.7-r2.ebuild
+++ b/x11-misc/xbindkeys/xbindkeys-1.8.7-r2.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit autotools
+
DESCRIPTION="Tool for launching commands on keystrokes"
SRC_URI="https://www.nongnu.org/${PN}/${P}.tar.gz"
HOMEPAGE="https://www.nongnu.org/xbindkeys/xbindkeys.html"
@@ -12,10 +14,6 @@ SLOT="0"
KEYWORDS="amd64 ~arm ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
IUSE="guile tk"
-PATCHES=(
- "${FILESDIR}/xbindkeys-1.8.7-guile3.patch"
-)
-
RDEPEND="
x11-libs/libX11
guile? ( >=dev-scheme/guile-1.8.4:=[deprecated] )
@@ -25,9 +23,19 @@ DEPEND="
${RDEPEND}
x11-base/xorg-proto
"
-DOCS="
- AUTHORS BUGS ChangeLog README TODO xbindkeysrc
-"
+
+DOCS=( AUTHORS BUGS ChangeLog README TODO xbindkeysrc )
+
+PATCHES=(
+ "${FILESDIR}/xbindkeys-1.8.7-guile3.patch"
+)
+
+src_prepare() {
+ default
+
+ # For guile patch, touches m4/
+ eautoreconf
+}
src_configure() {
econf \