summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-02-02 16:40:43 +0100
committerJeroen Roovers <jer@gentoo.org>2020-02-02 16:56:31 +0100
commit9971835a466a4c25a9d3b9ad4bebfb94d56f2cd8 (patch)
treead79cd7f24a1ca097d476853be571db8b83ff6c6 /x11-misc
parentdev-ruby/ruby2ruby: add ruby27, drop obsolete blocker (diff)
downloadgentoo-9971835a466a4c25a9d3b9ad4bebfb94d56f2cd8.tar.gz
gentoo-9971835a466a4c25a9d3b9ad4bebfb94d56f2cd8.tar.bz2
gentoo-9971835a466a4c25a9d3b9ad4bebfb94d56f2cd8.zip
x11-misc/xclip: Add live ebuild
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xclip/xclip-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-misc/xclip/xclip-9999.ebuild b/x11-misc/xclip/xclip-9999.ebuild
new file mode 100644
index 000000000000..12a50d1de869
--- /dev/null
+++ b/x11-misc/xclip/xclip-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools git-r3
+
+DESCRIPTION="Copy data from standard input to X clipboard"
+HOMEPAGE="https://github.com/astrand/xclip"
+EGIT_REPO_URI="https://github.com/astrand/${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXmu
+"
+
+DEPEND="
+ ${RDEPEND}
+ x11-libs/libXt
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}