summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-07-17 11:51:19 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-07-17 11:55:22 +0100
commit3c99ca3ba8d955afefadccb4be23affce8e6642f (patch)
tree18a379f17d2857380e24245e11627fe176558669 /x11-plugins/pidgin-window_merge
parentsys-process/below: update LICENSE (diff)
downloadgentoo-3c99ca3ba8d955afefadccb4be23affce8e6642f.tar.gz
gentoo-3c99ca3ba8d955afefadccb4be23affce8e6642f.tar.bz2
gentoo-3c99ca3ba8d955afefadccb4be23affce8e6642f.zip
x11-plugins/pidgin-window_merge: bump up to EAPI=8
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'x11-plugins/pidgin-window_merge')
-rw-r--r--x11-plugins/pidgin-window_merge/pidgin-window_merge-0.3-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-window_merge/pidgin-window_merge-0.3-r1.ebuild b/x11-plugins/pidgin-window_merge/pidgin-window_merge-0.3-r1.ebuild
new file mode 100644
index 000000000000..5fbc54811550
--- /dev/null
+++ b/x11-plugins/pidgin-window_merge/pidgin-window_merge-0.3-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A Pidgin plugin that merges the Buddy List window with a conversation window"
+HOMEPAGE="https://github.com/dm0-/window_merge"
+SRC_URI="https://github.com/downloads/dm0-/${PN#pidgin-}/${P#pidgin-}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2=
+ net-im/pidgin:0=[gtk]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P#pidgin-}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ ewarn "This plugin and infopane plugin (purple-plugin_pack) activated"
+ ewarn "at the same time cause a segfault in pidgin"
+ ewarn "see https://github.com/dm0-/window_merge/issues/4"
+}