summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-01-03 00:27:09 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2021-01-03 00:32:19 +0100
commit5c0943933f9e5a6875b801c2b9b3fd81585023c4 (patch)
treeaafef3f7aa9ff06c40947bd8d0956019899ff3d6 /x11-plugins
parentx11-plugins/wmsystemtray: do not call ar directly (diff)
downloadgentoo-5c0943933f9e5a6875b801c2b9b3fd81585023c4.tar.gz
gentoo-5c0943933f9e5a6875b801c2b9b3fd81585023c4.tar.bz2
gentoo-5c0943933f9e5a6875b801c2b9b3fd81585023c4.zip
x11-plugins/wmweather+: do not call ar directly
Closes: https://bugs.gentoo.org/726248 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmweather+/files/wmweather+-2.18-ar.patch11
-rw-r--r--x11-plugins/wmweather+/wmweather+-2.18.ebuild10
2 files changed, 20 insertions, 1 deletions
diff --git a/x11-plugins/wmweather+/files/wmweather+-2.18-ar.patch b/x11-plugins/wmweather+/files/wmweather+-2.18-ar.patch
new file mode 100644
index 000000000000..f87fdfa0ef08
--- /dev/null
+++ b/x11-plugins/wmweather+/files/wmweather+-2.18-ar.patch
@@ -0,0 +1,11 @@
+diff -Naur wmweather+-2.18.orig/configure.ac wmweather+-2.18/configure.ac
+--- wmweather+-2.18.orig/configure.ac 2020-04-24 20:31:43.000000000 +0200
++++ wmweather+-2.18/configure.ac 2021-01-03 00:25:30.443705781 +0100
+@@ -18,6 +18,7 @@
+ AC_SUBST(WMGENERAL_GUI)
+
+ # Checks for programs.
++AM_PROG_AR
+ AC_PROG_AWK
+ AC_PROG_CC
+ AC_PROG_CC_STDC
diff --git a/x11-plugins/wmweather+/wmweather+-2.18.ebuild b/x11-plugins/wmweather+/wmweather+-2.18.ebuild
index 01b450a84cce..7dffde689df7 100644
--- a/x11-plugins/wmweather+/wmweather+-2.18.ebuild
+++ b/x11-plugins/wmweather+/wmweather+-2.18.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit autotools
DESCRIPTION="A dockapp for displaying data collected from METAR, AVN, ETA, and MRF forecasts"
HOMEPAGE="https://www.sourceforge.net/projects/wmweatherplus/"
@@ -19,3 +20,10 @@ DEPEND="dev-libs/libpcre
x11-libs/libX11
x11-wm/windowmaker"
RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-ar.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}