summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-01-03 00:24:48 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2021-01-03 00:32:19 +0100
commita96a257e0e3856f454539f264fecbecf664ad06b (patch)
tree3de283a558757a6bff19666d04216cd9468f881b /x11-plugins
parentx11-plugins/wmpasman: do not call ar directly (diff)
downloadgentoo-a96a257e0e3856f454539f264fecbecf664ad06b.tar.gz
gentoo-a96a257e0e3856f454539f264fecbecf664ad06b.tar.bz2
gentoo-a96a257e0e3856f454539f264fecbecf664ad06b.zip
x11-plugins/wmsystemtray: do not call ar directly
Closes: https://bugs.gentoo.org/726224 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmsystemtray/files/wmsystemtray-1.4-ar.patch11
-rw-r--r--x11-plugins/wmsystemtray/wmsystemtray-1.4-r2.ebuild10
2 files changed, 20 insertions, 1 deletions
diff --git a/x11-plugins/wmsystemtray/files/wmsystemtray-1.4-ar.patch b/x11-plugins/wmsystemtray/files/wmsystemtray-1.4-ar.patch
new file mode 100644
index 000000000000..785893a989fd
--- /dev/null
+++ b/x11-plugins/wmsystemtray/files/wmsystemtray-1.4-ar.patch
@@ -0,0 +1,11 @@
+diff -Naur wmsystemtray-1.4.orig/configure.ac wmsystemtray-1.4/configure.ac
+--- wmsystemtray-1.4.orig/configure.ac 2014-02-23 03:14:09.000000000 +0100
++++ wmsystemtray-1.4/configure.ac 2021-01-03 00:23:12.004713692 +0100
+@@ -9,6 +9,7 @@
+ AC_SUBST(VERSION)
+
+ # Checks for programs.
++AM_PROG_AR
+ AC_PROG_AWK
+ AC_PROG_CC
+ AC_PROG_CC_STDC
diff --git a/x11-plugins/wmsystemtray/wmsystemtray-1.4-r2.ebuild b/x11-plugins/wmsystemtray/wmsystemtray-1.4-r2.ebuild
index 568d2c1936e0..47d0230996a8 100644
--- a/x11-plugins/wmsystemtray/wmsystemtray-1.4-r2.ebuild
+++ b/x11-plugins/wmsystemtray/wmsystemtray-1.4-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit autotools
DESCRIPTION="a system tray dockapp with the ability to display more than just four tray icons"
HOMEPAGE="https://sourceforge.net/projects/wmsystemtray/"
@@ -16,3 +17,10 @@ DEPEND="x11-libs/libXext
x11-libs/libXmu
x11-libs/libXpm"
RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-ar.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}