summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPablo <pord@tuta.io>2020-04-05 12:42:41 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-04-05 17:26:44 +0300
commit132211216ff9b61393fb3bd20cbb338a453c68fa (patch)
treefffa14d78c7fe2296955b31f891be69fca4c3cb2 /x11-terms/kitty-terminfo/files
parentapp-arch/engrampa: reorder eclass inherits (diff)
downloadgentoo-132211216ff9b61393fb3bd20cbb338a453c68fa.tar.gz
gentoo-132211216ff9b61393fb3bd20cbb338a453c68fa.tar.bz2
gentoo-132211216ff9b61393fb3bd20cbb338a453c68fa.zip
x11-terms/kitty-terminfo: bump to 0.17.2
Signed-off-by: Pablo Orduna <pabloorduna98@gmail.com> Closes: https://bugs.gentoo.org/716128 Closes: https://github.com/gentoo/gentoo/pull/15227 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-terms/kitty-terminfo/files')
-rw-r--r--x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.17.2.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.17.2.patch b/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.17.2.patch
new file mode 100644
index 000000000000..31aa669e0a5e
--- /dev/null
+++ b/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.17.2.patch
@@ -0,0 +1,44 @@
+--- a/setup.py 2020-03-12 00:28:46.725956882 +0100
++++ b/setup.py 2020-03-12 00:38:55.557945979 +0100
+@@ -876,6 +876,14 @@
+ create_macos_bundle_gunk(ddir)
+ # }}}
+
++def terminfo(args):
++ ddir = args.prefix
++ libdir = os.path.join(ddir, args.libdir_name.strip('/'), 'kitty')
++ build_terminfo = runpy.run_path('build-terminfo', run_name='import_build')
++ for x in (libdir, os.path.join(ddir, 'share')):
++ odir = os.path.join(x, 'terminfo')
++ safe_makedirs(odir)
++ build_terminfo['compile_terminfo'](odir)
+
+ def clean():
+
+@@ -889,7 +897,7 @@
+
+ safe_remove(
+ 'build', 'compile_commands.json', 'link_commands.json',
+- 'linux-package', 'kitty.app', 'asan-launcher',
++ 'linux-package', 'linux-terminfo', 'kitty.app', 'asan-launcher',
+ 'kitty-profile', 'kitty/launcher')
+ exclude = ('.git',)
+ for root, dirs, files in os.walk('.', topdown=True):
+@@ -910,7 +918,7 @@
+ 'action',
+ nargs='?',
+ default=Options.action,
+- choices='build test linux-package kitty.app linux-freeze macos-freeze clean'.split(),
++ choices='build test linux-package linux-terminfo kitty.app linux-freeze macos-freeze clean'.split(),
+ help='Action to perform (default is build)'
+ )
+ p.add_argument(
+@@ -1007,6 +1015,8 @@
+ elif args.action == 'linux-package':
+ build(args, native_optimizations=False)
+ package(args, bundle_type='linux-package')
++ elif args.action == 'linux-terminfo':
++ terminfo(args)
+ elif args.action == 'linux-freeze':
+ build(args, native_optimizations=False)
+ package(args, bundle_type='linux-freeze')