summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPablo <pord@tuta.io>2020-04-05 12:42:41 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-04-05 17:26:44 +0300
commit132211216ff9b61393fb3bd20cbb338a453c68fa (patch)
treefffa14d78c7fe2296955b31f891be69fca4c3cb2 /x11-terms/kitty-terminfo/kitty-terminfo-0.17.2.ebuild
parentapp-arch/engrampa: reorder eclass inherits (diff)
downloadgentoo-132211216ff9b61393fb3bd20cbb338a453c68fa.tar.gz
gentoo-132211216ff9b61393fb3bd20cbb338a453c68fa.tar.bz2
gentoo-132211216ff9b61393fb3bd20cbb338a453c68fa.zip
x11-terms/kitty-terminfo: bump to 0.17.2
Signed-off-by: Pablo Orduna <pabloorduna98@gmail.com> Closes: https://bugs.gentoo.org/716128 Closes: https://github.com/gentoo/gentoo/pull/15227 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-terms/kitty-terminfo/kitty-terminfo-0.17.2.ebuild')
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.17.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.17.2.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.17.2.ebuild
new file mode 100644
index 000000000000..b37c1bba5c12
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.17.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-any-r1 toolchain-funcs xdg
+
+DESCRIPTION="Terminfo for kitty, an OpenGL-based terminal emulator"
+HOMEPAGE="https://github.com/kovidgoyal/kitty"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="${PYTHON_DEPS}"
+
+PATCHES=(
+ "${FILESDIR}"/kitty-terminfo-setup-0.17.2.patch
+)
+
+# kitty-terminfo is a split package from kitty that only installs the terminfo
+# file. As tests are designed to be run with the whole package compiled they
+# would fail in this case.
+RESTRICT="test"
+
+src_compile() {
+ "${EPYTHON}" setup.py \
+ --verbose $(usex debug --debug "") \
+ --libdir-name $(get_libdir) \
+ linux-terminfo || die "Failed to compile kitty."
+}
+
+src_install() {
+ insinto /usr
+ doins -r linux-package/*
+}