summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-12-15 15:45:20 +0100
committerPacho Ramos <pacho@gentoo.org>2019-12-15 16:22:28 +0100
commitd4d73299a867d6ecfcb9247c34b363bc82938bec (patch)
tree090fa2df82706f4ba10cd8d7229c23f3819e3234 /x11-themes/QGnomePlatform/QGnomePlatform-0.6.0.ebuild
parentdev-python/zope-event: ppc stable wrt bug #700626 (diff)
downloadgentoo-d4d73299a867d6ecfcb9247c34b363bc82938bec.tar.gz
gentoo-d4d73299a867d6ecfcb9247c34b363bc82938bec.tar.bz2
gentoo-d4d73299a867d6ecfcb9247c34b363bc82938bec.zip
x11-themes/QGnomePlatform: Bump to 0.6
Package-Manager: Portage-2.3.81, Repoman-2.3.19 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-themes/QGnomePlatform/QGnomePlatform-0.6.0.ebuild')
-rw-r--r--x11-themes/QGnomePlatform/QGnomePlatform-0.6.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-themes/QGnomePlatform/QGnomePlatform-0.6.0.ebuild b/x11-themes/QGnomePlatform/QGnomePlatform-0.6.0.ebuild
new file mode 100644
index 000000000000..ed5ca4043cd7
--- /dev/null
+++ b/x11-themes/QGnomePlatform/QGnomePlatform-0.6.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qmake-utils
+
+DESCRIPTION="A Qt Platform Theme aimed to accommodate GNOME settings"
+HOMEPAGE="https://github.com/FedoraQt/QGnomePlatform"
+SRC_URI="https://github.com/FedoraQt/QGnomePlatform/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc64 ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-qt/qtwidgets-5.6:5=
+ dev-qt/qtwayland:5=
+ x11-libs/gtk+:3[X]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ INSTALL_ROOT="${D}" default
+}