summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/QGnomePlatform/QGnomePlatform-0.6.0.ebuild')
-rw-r--r--x11-themes/QGnomePlatform/QGnomePlatform-0.6.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-themes/QGnomePlatform/QGnomePlatform-0.6.0.ebuild b/x11-themes/QGnomePlatform/QGnomePlatform-0.6.0.ebuild
new file mode 100644
index 000000000000..ed5ca4043cd7
--- /dev/null
+++ b/x11-themes/QGnomePlatform/QGnomePlatform-0.6.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qmake-utils
+
+DESCRIPTION="A Qt Platform Theme aimed to accommodate GNOME settings"
+HOMEPAGE="https://github.com/FedoraQt/QGnomePlatform"
+SRC_URI="https://github.com/FedoraQt/QGnomePlatform/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc64 ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-qt/qtwidgets-5.6:5=
+ dev-qt/qtwayland:5=
+ x11-libs/gtk+:3[X]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ INSTALL_ROOT="${D}" default
+}