summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-23 00:32:53 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-23 00:35:50 +0100
commit19f19186a37e74d5dccc5364432a092f66dfa5f7 (patch)
treed5d510096b937c6d75b7aa34be84dc0273bba069 /xfce-base
parentxfce-base/thunar: Bump to 4.16.0 (diff)
downloadgentoo-19f19186a37e74d5dccc5364432a092f66dfa5f7.tar.gz
gentoo-19f19186a37e74d5dccc5364432a092f66dfa5f7.tar.bz2
gentoo-19f19186a37e74d5dccc5364432a092f66dfa5f7.zip
xfce-base/exo: Bump to 4.16.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/exo/Manifest1
-rw-r--r--xfce-base/exo/exo-4.16.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/xfce-base/exo/Manifest b/xfce-base/exo/Manifest
index ced6ff1569b3..18cb03d35df5 100644
--- a/xfce-base/exo/Manifest
+++ b/xfce-base/exo/Manifest
@@ -1,2 +1,3 @@
DIST exo-0.12.11.tar.bz2 1333227 BLAKE2B 4e95809c58b6db26ecdf524663c06df9cd70007726091e381a1f0dd58be52efee85ad9721c421c0df6438073bb9de97d56cd039f520e2f7c0f5722a1839ba167 SHA512 ecbf20feddf86178d34a5c70212f0c2310ab1d6ce25291846d6d1d3045270ae3e68102065d7b3d8840137406f826f9bc37fed92a16c1268c3d14f2833a97d533
DIST exo-4.15.3.tar.bz2 994455 BLAKE2B 9c62b31a2f5cba4853263ea0b155fc3e5439170c7cc3011c03022a5419a9a0910c4b47431cf916f6e6ad4a5d2580e488ba8a18e4bbaa4d97d35a61711fd4a93a SHA512 3da0a0aadd15e140e43eece56bb92872e05f90b0da88368a84f3d3bc8d53c19d12549693fe00518937a691a3af559d1dba3170fa2490a64dbc26fa2f7faf13ea
+DIST exo-4.16.0.tar.bz2 966143 BLAKE2B ee2175d2d5087e948a6fb9bd4ffed2ecfe54be7078d2f1c55a6b30a0f3920689a46372af749035b1454e74ef5c75037996f3601d76adf1d0067eceba6775df76 SHA512 8fff640c4a229e77911cf091866f265e1f0d7f0b9274b1a879f46061644dd6aec07ae3f8fc43ac7277429ea98bdde8d0ee010da7ed398cddc7d755fea91b964c
diff --git a/xfce-base/exo/exo-4.16.0.ebuild b/xfce-base/exo/exo-4.16.0.ebuild
new file mode 100644
index 000000000000..f67b97867965
--- /dev/null
+++ b/xfce-base/exo/exo-4.16.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+RDEPEND=">=dev-libs/glib-2.50
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.15.1:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.12:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}